summaryrefslogtreecommitdiff
path: root/plugins/supereq/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/supereq/Makefile.am')
-rw-r--r--plugins/supereq/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/plugins/supereq/Makefile.am b/plugins/supereq/Makefile.am
index 0fffd6d6..eecade68 100644
--- a/plugins/supereq/Makefile.am
+++ b/plugins/supereq/Makefile.am
@@ -3,7 +3,9 @@ supereqdir = $(libdir)/$(PACKAGE)
pkglib_LTLIBRARIES = supereq.la
supereq_la_SOURCES = supereq.c supereq.h Equ.cpp Fftsg_fl.cpp paramlist.hpp
-supereq_la_LDFLAGS = -module
+AM_CPPFLAGS = $(CXXFLAGS) -fno-exceptions -fno-rtti -nostdlib -fno-unwind-tables
+
+supereq_la_LDFLAGS = -module -nostdlib -lsupc++
supereq_la_LIBADD = $(LDADD)
AM_CFLAGS = -std=c99