summaryrefslogtreecommitdiff
path: root/plugins/shn/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/shn/Makefile.am')
-rw-r--r--plugins/shn/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/plugins/shn/Makefile.am b/plugins/shn/Makefile.am
new file mode 100644
index 00000000..44671140
--- /dev/null
+++ b/plugins/shn/Makefile.am
@@ -0,0 +1,10 @@
+if HAVE_SHN
+shndir = $(libdir)/$(PACKAGE)
+pkglib_LTLIBRARIES = shn.la
+shn_la_SOURCES = array.c config.h convert.c misc.c output.c seek.c shn.c shn.h shorten.c shorten.h sulawalaw.c vario.c wave.c
+
+shn_la_LDFLAGS = -module
+
+shn_la_LIBADD = $(LDADD)
+AM_CFLAGS = $(CFLAGS) -std=c99
+endif