summaryrefslogtreecommitdiff
path: root/plugins/shellexec/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/shellexec/Makefile.am')
-rw-r--r--plugins/shellexec/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/plugins/shellexec/Makefile.am b/plugins/shellexec/Makefile.am
new file mode 100644
index 00000000..65d6a5b8
--- /dev/null
+++ b/plugins/shellexec/Makefile.am
@@ -0,0 +1,9 @@
+if HAVE_SHELLEXEC
+shxdir = $(libdir)/$(PACKAGE)
+pkglib_LTLIBRARIES = shellexec.la
+shellexec_la_SOURCES = shellexec.c
+shellexec_la_LDFLAGS = -module
+
+shellexec_la_LIBADD = $(LDADD) $(HOTKEYS_LIBS)
+AM_CFLAGS = $(CFLAGS) -std=c99
+endif