summaryrefslogtreecommitdiff
path: root/plugins/mono2stereo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/mono2stereo/Makefile')
-rw-r--r--plugins/mono2stereo/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/plugins/mono2stereo/Makefile b/plugins/mono2stereo/Makefile
new file mode 100644
index 00000000..067f074d
--- /dev/null
+++ b/plugins/mono2stereo/Makefile
@@ -0,0 +1,23 @@
+CC=gcc
+
+CFLAGS+=-Wall -fPIC -D_GNU_SOURCE -std=c99
+
+LDFLAGS+=-module -shared -lm
+
+SOURCES=mono2stereo.c
+
+OBJECTS=$(SOURCES:.c=.o)
+
+OUT=mono2stereo.so
+
+all: $(SOURCES) $(OUT)
+
+$(OUT): $(OBJECTS)
+ $(CC) $(LDFLAGS) $(OBJECTS) -o $@
+
+.c.o:
+ $(CC) $(CFLAGS) $< -c -o $@
+
+clean:
+ rm $(OBJECTS) $(OUT)
+