summaryrefslogtreecommitdiff
path: root/plugins/hotkeys/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/hotkeys/Makefile.am')
-rw-r--r--plugins/hotkeys/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/plugins/hotkeys/Makefile.am b/plugins/hotkeys/Makefile.am
new file mode 100644
index 00000000..4f08e6eb
--- /dev/null
+++ b/plugins/hotkeys/Makefile.am
@@ -0,0 +1,9 @@
+hotkeysdir = $(libdir)/$(PACKAGE)
+pkglib_LTLIBRARIES = hotkeys.la
+hotkeys_la_SOURCES = hotkeys.c
+hotkeys_la_LDFLAGS = -module
+
+EXTRA_hotkeys_la_SOURCES = keysyms.inc
+
+hotkeys_la_LIBADD = $(LDADD) $(hotkeys_DEPS_LIBS)
+AM_CFLAGS = $(hotkeys_DEPS_CFLAGS) -std=c99