summaryrefslogtreecommitdiff
path: root/plugins/artwork/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/artwork/Makefile.am')
-rw-r--r--plugins/artwork/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/plugins/artwork/Makefile.am b/plugins/artwork/Makefile.am
index de137844..403a30e2 100644
--- a/plugins/artwork/Makefile.am
+++ b/plugins/artwork/Makefile.am
@@ -1,8 +1,10 @@
+if HAVE_ARTWORK
artworkdir = $(libdir)/$(PACKAGE)
pkglib_LTLIBRARIES = artwork.la
-artwork_la_SOURCES = artwork.h albumartorg.c artwork.c lastfm.c
+artwork_la_SOURCES = artwork.c artwork.h albumartorg.c albumartorg.h lastfm.c lastfm.h
artwork_la_LDFLAGS = -module
artwork_la_LIBADD = $(LDADD) $(ARTWORK_DEPS_LIBS) $(CURL_LIBS)
AM_CFLAGS = -std=c99 $(ARTWORK_DEPS_CFLAGS)
+endif