summaryrefslogtreecommitdiff
path: root/plugins/ao/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/ao/Makefile')
-rw-r--r--plugins/ao/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/plugins/ao/Makefile b/plugins/ao/Makefile
index 0714690c..9c4285b8 100644
--- a/plugins/ao/Makefile
+++ b/plugins/ao/Makefile
@@ -4,9 +4,9 @@ CC=gcc
ZLIB_LIBS=-lz
-CFLAGS+=-Wall -DPATH_MAX=1024 -DHAS_PSXCPU=1 -I../.. -I./ -Ieng_ssf -Ieng_qsf -Ieng_dsf
+CFLAGS+=-Wall -fPIC -DPATH_MAX=1024 -DHAS_PSXCPU=1 -I../.. -I./ -Ieng_ssf -Ieng_qsf -Ieng_dsf
-LDFLAGS+=-module -shared -fPIC $(ZLIB_LIBS) -lm
+LDFLAGS+=-module -shared $(ZLIB_LIBS) -lm
SOURCES=plugin.c main.c corlett.c\
eng_dsf/eng_dsf.c eng_dsf/dc_hw.c eng_dsf/aica.c eng_dsf/aicadsp.c eng_dsf/arm7.c eng_dsf/arm7i.c\