summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules3
1 files changed, 3 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index b544bd5e..fb6cce67 100755
--- a/debian/rules
+++ b/debian/rules
@@ -7,9 +7,11 @@ export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
%:
dh $@ --parallel --with autoreconf
+.PHONY: override_dh_autoreconf
override_dh_autoreconf:
dh_autoreconf sh -- autogen.sh
+.PHONY: override_dh_auto_configure
override_dh_auto_configure:
dh_auto_configure -- \
--disable-nullout \
@@ -72,5 +74,6 @@ override_dh_install:
-$(RM) debian/deadbeef/usr/lib/*/deadbeef/*.so.0*
dh_install -XCOPYING.GPLv2 -XCOPYING.LGPLv2.1 --fail-missing
+.PHONY: override_dh_installdocs
override_dh_installdocs:
dh_installdocs -XREADME