summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 84025ff1..86f91d4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -72,6 +72,7 @@ AC_ARG_ENABLE(flac, [ --disable-flac build FLAC player plugin (def
AC_ARG_ENABLE(sndfile, [ --disable-sndfile build libsndfile plugin for PCM wave files (default: enabled)], [enable_sndfile=$enableval], [enable_sndfile=yes])
AC_ARG_ENABLE(wavpack, [ --disable-wavpack build wavpack plugin (default: enabled)], [enable_wavpack=$enableval], [enable_wavpack=yes])
AC_ARG_ENABLE(cdda, [ --disable-cdda build CD-Audio plugin (default: enabled)], [enable_cdda=$enableval], [enable_cdda=yes])
+AC_ARG_ENABLE(gme, [ --disable-gme build Game Music Emu plugin for NFS, AY, etc (default: enabled)], [enable_cdda=$enableval], [enable_gme=yes])
AC_ARG_ENABLE(libnotify, [ --enable-libnotify include support for OSD notifications into GTKUI plugin (default: no)], [enable_libnotify=$enableval], [enable_libnotify=no])
@@ -358,6 +359,11 @@ if test "x$enable_vtx" != "xno" ; then
PLUGINS_DIRS="$PLUGINS_DIRS plugins/vtx"
fi
+if test "x$enable_gme" != "xno" ; then
+ HAVE_GME=yes
+ PLUGINS_DIRS="$PLUGINS_DIRS plugins/gme"
+fi
+
AC_SUBST(PLUGINS_DIRS)
echo
@@ -384,7 +390,7 @@ AC_DEFUN([PRINT_PLUGIN_INFO],
)
PRINT_PLUGIN_INFO([stdio],[Standard IO plugin],[true])
-PRINT_PLUGIN_INFO([gme],[chiptune music player based on GME],[true])
+PRINT_PLUGIN_INFO([gme],[chiptune music player based on GME],[test "x$HAVE_GME" = "xyes"])
PRINT_PLUGIN_INFO([dumb],[module player based on DUMB library],[true])
PRINT_PLUGIN_INFO([nullout],[NULL output],[test "x$HAVE_NULLOUT" = "xyes"])
PRINT_PLUGIN_INFO([alsa],[ALSA output],[test "x$HAVE_ALSA" = "xyes"])
@@ -418,8 +424,9 @@ AC_OUTPUT([
Makefile
pixmaps/Makefile
icons/Makefile
-gme/Game_Music_Emu-0.5.2/Makefile
-gme/Game_Music_Emu-0.5.2/gme/Makefile
+plugins/gme/Makefile
+plugins/gme/Game_Music_Emu-0.5.2/Makefile
+plugins/gme/Game_Music_Emu-0.5.2/gme/Makefile
plugins/sid/sidplay-libs/Makefile
dumb/Makefile
plugins/alsa/Makefile