summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog10
-rw-r--r--configure.in15
-rw-r--r--plugins/lastfm/Makefile.am3
3 files changed, 15 insertions, 13 deletions
diff --git a/ChangeLog b/ChangeLog
index 9f5f1f1a..71bc5fe7 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,13 @@
+version 0.2.1
+ new ape decoder - faster, doesn't crash
+ fixed APEv2 tag reader
+ fixed id3 tag reader on big-endian systems
+ player now builds without errors on big-endian systems
+ memory for HSVC song length database is now allocated on demand
+ fixed icons in system tray menu
+ fixed color detection for column header text
+ improved cuesheet reader (pregap support and better bounds checking)
+
version 0.2.0
plugin API - decoder and misc plugins working, other types are work in progress
most decoders are in plugins now, which means that most dependencies are optional (libmad, libFLAC, etc)
diff --git a/configure.in b/configure.in
index 22dcdd5a..6f131da3 100644
--- a/configure.in
+++ b/configure.in
@@ -3,7 +3,7 @@ AC_INIT
AC_CONFIG_HEADER(config.h)
PACKAGE="deadbeef"
-VERSION="0.2.1-dev"
+VERSION="0.2.1"
AM_INIT_AUTOMAKE($PACKAGE,$VERSION)
@@ -28,18 +28,9 @@ PKG_CHECK_MODULES(DEPS, gtk+-2.0 >= 2.12 gthread-2.0 glib-2.0 samplerate alsa)
AX_EXT()
-dnl ape plugin
-dnl AC_CHECK_LIB([mac], [main], [HAVE_LIBMAC=1])
-dnl if test ${HAVE_LIBMAC}; then
-dnl APE_LIBS="-lmac"
-dnl APE_DIR="plugins/ape"
-dnl AC_SUBST(APE_LIBS)
-dnl AC_SUBST(APE_DIR)
-dnl fi
-
dnl lastfm plugin
-AC_CHECK_LIB([libcurl], [main], [HAVE_LIBCURL=1])
-if test ${HAVE_LIBCURL}; then
+AC_CHECK_LIB([curl], [main], [HAVE_CURL=1])
+if test ${HAVE_CURL}; then
LFM_LIBS="-lmad"
LFM_DIR="plugins/lastfm"
AC_SUBST(LFM_LIBS)
diff --git a/plugins/lastfm/Makefile.am b/plugins/lastfm/Makefile.am
index 24fb0f4b..c9e1e9b3 100644
--- a/plugins/lastfm/Makefile.am
+++ b/plugins/lastfm/Makefile.am
@@ -3,5 +3,6 @@ pkglib_LTLIBRARIES = lastfm.la
lastfm_la_SOURCES = lastfm.c
lastfm_la_LDFLAGS = -module
-lastfm_la_LIBADD = $(LDADD) $(LASTFM_DEPS_LIBS)
+lastfm_la_LIBADD = $(LDADD) $(LFM_LIBS)
AM_CFLAGS = $(LASTFM_DEPS_CFLAGS) -std=c99
+