summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac2
-rw-r--r--main.c3
2 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ff8615aa..844d45a0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@ AC_INIT
AC_CONFIG_HEADER(config.h)
PACKAGE="deadbeef"
-VERSION="0.3.2-rc2"
+VERSION="0.3.2-dev"
AM_INIT_AUTOMAKE($PACKAGE,$VERSION)
diff --git a/main.c b/main.c
index a9d47812..95dbaa71 100644
--- a/main.c
+++ b/main.c
@@ -364,6 +364,7 @@ static int sigterm_handled = 0;
void
atexit_handler (void) {
+ fprintf (stderr, "atexit_handler\n");
if (!sigterm_handled) {
fprintf (stderr, "handling atexit.\n");
pl_save (defpl);
@@ -528,7 +529,7 @@ main (int argc, char *argv[]) {
messagepump_init (); // required to push messages while handling commandline
plug_load_all (); // required to add files to playlist from commandline
- //atexit (atexit_handler); // doesn't help on X11 server shutdown anyway
+ atexit (atexit_handler); // helps to save in simple cases, like xkill
// execute server commands in local context
int noloadpl = 0;