summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac2
-rw-r--r--plugins/vorbis/vorbis.c3
2 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b55e861e..a2758e5e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@ AC_INIT
AC_CONFIG_HEADER(config.h)
PACKAGE="deadbeef"
-VERSION="0.3.0-rc2"
+VERSION="0.3.0-rc3"
AM_INIT_AUTOMAKE($PACKAGE,$VERSION)
diff --git a/plugins/vorbis/vorbis.c b/plugins/vorbis/vorbis.c
index 2a10322c..e3568099 100644
--- a/plugins/vorbis/vorbis.c
+++ b/plugins/vorbis/vorbis.c
@@ -83,6 +83,9 @@ update_vorbis_comments (DB_playItem_t *it, vorbis_comment *vc) {
else if (!strncasecmp (vc->user_comments[i], "title=", 6)) {
deadbeef->pl_add_meta (it, "title", vc->user_comments[i] + 6);
}
+ else if (!strncasecmp (vc->user_comments[i], "tracknumber=", 12)) {
+ deadbeef->pl_add_meta (it, "track", vc->user_comments[i] + 12);
+ }
else if (!strncasecmp (vc->user_comments[i], "date=", 5)) {
deadbeef->pl_add_meta (it, "date", vc->user_comments[i] + 5);
}