summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog3
-rw-r--r--configure.ac2
-rwxr-xr-xscripts/portable_package_partial.sh36
3 files changed, 3 insertions, 38 deletions
diff --git a/ChangeLog b/ChangeLog
index 17056149..ba19f992 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -3,6 +3,7 @@ version 0.5.0
added support for output in 8,24,32,float32 bits per sample formats
improved replaygain support, with new options
new DSP plugin API, allowing format conversions, time stretching and multiple instances
+ configurable DSP chains
added VGZ support to GME plugin
moved libsamplerate resampler to separate DSP plugin
added new playlist plugin API
@@ -10,7 +11,7 @@ version 0.5.0
added Edit->Sort By menu entry, with flexible sort options
DUMB, AOSDK, SHN plugins are not distributed in deadbeef tarball anymore
added "Shuffle albums" mode
- improved metadata editing, allowing modification of any text fields, including custom
+ improved metadata editing, allowing modification of any text fields, including custom fields
added support for editing metadata for multiple selected tracks
improved Album Artist support
added album covers to notifications
diff --git a/configure.ac b/configure.ac
index 97228d05..09942782 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([deadbeef], [0.5.0-beta1])
+AC_INIT([deadbeef], [devel])
AC_CONFIG_HEADER(config.h)
diff --git a/scripts/portable_package_partial.sh b/scripts/portable_package_partial.sh
deleted file mode 100755
index d3d63396..00000000
--- a/scripts/portable_package_partial.sh
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/bin/sh
-
-# package for distribution
-VERSION=`cat PORTABLE_VERSION | perl -ne 'chomp and print'`
-BUILD=`cat PORTABLE_BUILD | perl -ne 'chomp and print'`
-
-# main distro
-SRCDIR=deadbeef-$VERSION-portable
-PLUGDIR=$SRCDIR/plugins
-DOCDIR=$SRCDIR/doc
-PIXMAPDIR=$SRCDIR/pixmaps
-
-tar jcvf portable_out/build/deadbeef-$VERSION-portable-partial-r$BUILD.tar.bz2\
- $SRCDIR/deadbeef\
- $SRCDIR/deadbeef.png\
- $DOCDIR\
- $PLUGDIR/alsa.so\
- $PLUGDIR/oss.so\
- $PLUGDIR/vfs_curl.so\
- $PLUGDIR/artwork.so\
- $PLUGDIR/gtkui.so\
- $PLUGDIR/gtkui.fallback.so\
- $PLUGDIR/hotkeys.so\
- $PLUGDIR/cdda.so\
- $PLUGDIR/mpgmad.so\
- $PLUGDIR/vorbis.so\
- $PLUGDIR/wavpack.so\
- $PLUGDIR/flac.so\
- $PLUGDIR/ffap.so\
- $PLUGDIR/musepack.so\
- $PLUGDIR/notify.so\
- $PLUGDIR/sndfile.so\
- $PLUGDIR/supereq.so\
- $PLUGDIR/tta.so\
- $PIXMAPDIR
-