summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Makefile.am2
-rw-r--r--configure.in1
-rw-r--r--plugins/ape/ape.c38
-rw-r--r--plugins/ape/apewrapper.cpp24
-rw-r--r--plugins/ape/apewrapper.h24
-rw-r--r--plugins/demac/Makefile.am6
-rw-r--r--plugins/demac/demac.c57
-rw-r--r--plugins/demac/libdemac/SOURCES (renamed from libdemac/SOURCES)0
-rw-r--r--plugins/demac/libdemac/crc.c (renamed from libdemac/crc.c)0
-rw-r--r--plugins/demac/libdemac/decoder.c (renamed from libdemac/decoder.c)0
-rw-r--r--plugins/demac/libdemac/decoder.h (renamed from libdemac/decoder.h)0
-rw-r--r--plugins/demac/libdemac/demac.h (renamed from libdemac/demac.h)0
-rw-r--r--plugins/demac/libdemac/demac_config.h (renamed from libdemac/demac_config.h)0
-rw-r--r--plugins/demac/libdemac/entropy.c (renamed from libdemac/entropy.c)0
-rw-r--r--plugins/demac/libdemac/entropy.h (renamed from libdemac/entropy.h)0
-rw-r--r--plugins/demac/libdemac/filter.c (renamed from libdemac/filter.c)0
-rw-r--r--plugins/demac/libdemac/filter.h (renamed from libdemac/filter.h)0
-rw-r--r--plugins/demac/libdemac/filter_1280_15.c (renamed from libdemac/filter_1280_15.c)0
-rw-r--r--plugins/demac/libdemac/filter_16_11.c (renamed from libdemac/filter_16_11.c)0
-rw-r--r--plugins/demac/libdemac/filter_256_13.c (renamed from libdemac/filter_256_13.c)0
-rw-r--r--plugins/demac/libdemac/filter_32_10.c (renamed from libdemac/filter_32_10.c)0
-rw-r--r--plugins/demac/libdemac/filter_64_11.c (renamed from libdemac/filter_64_11.c)0
-rw-r--r--plugins/demac/libdemac/parser.c (renamed from libdemac/parser.c)0
-rw-r--r--plugins/demac/libdemac/parser.h (renamed from libdemac/parser.h)0
-rw-r--r--plugins/demac/libdemac/predictor-arm.S (renamed from libdemac/predictor-arm.S)0
-rw-r--r--plugins/demac/libdemac/predictor-cf.S (renamed from libdemac/predictor-cf.S)0
-rw-r--r--plugins/demac/libdemac/predictor.c (renamed from libdemac/predictor.c)0
-rw-r--r--plugins/demac/libdemac/predictor.h (renamed from libdemac/predictor.h)0
-rw-r--r--plugins/demac/libdemac/vector_math16_armv5te.h (renamed from libdemac/vector_math16_armv5te.h)0
-rw-r--r--plugins/demac/libdemac/vector_math16_armv6.h (renamed from libdemac/vector_math16_armv6.h)0
-rw-r--r--plugins/demac/libdemac/vector_math16_cf.h (renamed from libdemac/vector_math16_cf.h)0
-rw-r--r--plugins/demac/libdemac/vector_math32_armv4.h (renamed from libdemac/vector_math32_armv4.h)0
-rw-r--r--plugins/demac/libdemac/vector_math_generic.h (renamed from libdemac/vector_math_generic.h)0
33 files changed, 135 insertions, 17 deletions
diff --git a/Makefile.am b/Makefile.am
index 50637ce5..ceb64007 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,7 @@
ACLOCAL_AMFLAGS = -I m4
SUBDIRS = gme/Game_Music_Emu-0.5.2 gme/Game_Music_Emu-0.5.2/gme sid/sidplay-libs-2.1.0 dumb pixmaps\
- plugins/lastfm ${APE_DIR}
+ plugins/lastfm ${APE_DIR} plugins/demac
dumbpath=@top_srcdir@/dumb
sidpath=@top_srcdir@/sid/sidplay-libs-2.1.0
diff --git a/configure.in b/configure.in
index 2fa39e88..14eb0862 100644
--- a/configure.in
+++ b/configure.in
@@ -48,6 +48,7 @@ sid/sidplay-libs-2.1.0/Makefile
dumb/Makefile
plugins/lastfm/Makefile
plugins/ape/Makefile
+plugins/demac/Makefile
deadbeef.desktop
])
diff --git a/plugins/ape/ape.c b/plugins/ape/ape.c
index 619d8f1c..66e7af17 100644
--- a/plugins/ape/ape.c
+++ b/plugins/ape/ape.c
@@ -1,20 +1,26 @@
/*
- DeaDBeeF - ultimate music player for GNU/Linux systems with X11
- Copyright (C) 2009 Alexey Yakovenko
-
- This program is free software; you can redistribute it and/or
- modify it under the terms of the GNU General Public License
- as published by the Free Software Foundation; either version 2
- of the License, or (at your option) any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software
- Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+ apedec - Monkey's Audio Decoder plugin for DeaDBeeF player
+ http://deadbeef.sourceforge.net
+
+ Copyright (C) 2009 Alexey Yakovenko
+
+ This software is provided 'as-is', without any express or implied
+ warranty. In no event will the authors be held liable for any damages
+ arising from the use of this software.
+
+ Permission is granted to anyone to use this software for any purpose,
+ including commercial applications, and to alter it and redistribute it
+ freely, subject to the following restrictions:
+
+ 1. The origin of this software must not be misrepresented; you must not
+ claim that you wrote the original software. If you use this software
+ in a product, an acknowledgment in the product documentation would be
+ appreciated but is not required.
+ 2. Altered source versions must be plainly marked as such, and must not be
+ misrepresented as being the original software.
+ 3. This notice may not be removed or altered from any source distribution.
+
+ Note: DeaDBeeF player itself uses different license
*/
#include <stdio.h>
#include <string.h>
diff --git a/plugins/ape/apewrapper.cpp b/plugins/ape/apewrapper.cpp
index 995034f6..3e13136c 100644
--- a/plugins/ape/apewrapper.cpp
+++ b/plugins/ape/apewrapper.cpp
@@ -1,3 +1,27 @@
+/*
+ apedec - Monkey's Audio Decoder plugin for DeaDBeeF player
+ http://deadbeef.sourceforge.net
+
+ Copyright (C) 2009 Alexey Yakovenko
+
+ This software is provided 'as-is', without any express or implied
+ warranty. In no event will the authors be held liable for any damages
+ arising from the use of this software.
+
+ Permission is granted to anyone to use this software for any purpose,
+ including commercial applications, and to alter it and redistribute it
+ freely, subject to the following restrictions:
+
+ 1. The origin of this software must not be misrepresented; you must not
+ claim that you wrote the original software. If you use this software
+ in a product, an acknowledgment in the product documentation would be
+ appreciated but is not required.
+ 2. Altered source versions must be plainly marked as such, and must not be
+ misrepresented as being the original software.
+ 3. This notice may not be removed or altered from any source distribution.
+
+ Note: DeaDBeeF player itself uses different license
+*/
#include <mac/All.h>
#include <mac/GlobalFunctions.h>
#include <mac/MACLib.h>
diff --git a/plugins/ape/apewrapper.h b/plugins/ape/apewrapper.h
index 27da0f36..ca3c0f92 100644
--- a/plugins/ape/apewrapper.h
+++ b/plugins/ape/apewrapper.h
@@ -1,3 +1,27 @@
+/*
+ apedec - Monkey's Audio Decoder plugin for DeaDBeeF player
+ http://deadbeef.sourceforge.net
+
+ Copyright (C) 2009 Alexey Yakovenko
+
+ This software is provided 'as-is', without any express or implied
+ warranty. In no event will the authors be held liable for any damages
+ arising from the use of this software.
+
+ Permission is granted to anyone to use this software for any purpose,
+ including commercial applications, and to alter it and redistribute it
+ freely, subject to the following restrictions:
+
+ 1. The origin of this software must not be misrepresented; you must not
+ claim that you wrote the original software. If you use this software
+ in a product, an acknowledgment in the product documentation would be
+ appreciated but is not required.
+ 2. Altered source versions must be plainly marked as such, and must not be
+ misrepresented as being the original software.
+ 3. This notice may not be removed or altered from any source distribution.
+
+ Note: DeaDBeeF player itself uses different license
+*/
#ifndef __APEWRAPPER_H
#define __APEWRAPPER_H
diff --git a/plugins/demac/Makefile.am b/plugins/demac/Makefile.am
new file mode 100644
index 00000000..e1296c5e
--- /dev/null
+++ b/plugins/demac/Makefile.am
@@ -0,0 +1,6 @@
+demacdir = $(libdir)/$(PACKAGE)
+pkglib_LTLIBRARIES = demac.la
+demac_la_SOURCES = demac.c
+demac_la_LDFLAGS = -module
+#demac_la_LIBADD = $(LDADD) $(demac_LIBS)
+#AM_CFLAGS = $(demac_DEPS_CFLAGS) -std=c99
diff --git a/plugins/demac/demac.c b/plugins/demac/demac.c
new file mode 100644
index 00000000..a757ebfb
--- /dev/null
+++ b/plugins/demac/demac.c
@@ -0,0 +1,57 @@
+/*
+ DeaDBeeF - ultimate music player for GNU/Linux systems with X11
+ Copyright (C) 2009 Alexey Yakovenko
+
+ This program is free software; you can redistribute it and/or
+ modify it under the terms of the GNU General Public License
+ as published by the Free Software Foundation; either version 2
+ of the License, or (at your option) any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
+*/
+#include <stdio.h>
+#include <string.h>
+#include <time.h>
+#include "../../deadbeef.h"
+
+#define min(x,y) ((x)<(y)?(x):(y))
+#define max(x,y) ((x)>(y)?(x):(y))
+
+static DB_decoder_t plugin;
+static DB_functions_t *deadbeef;
+
+static const char *exts[] = { "ape", NULL };
+static const char *filetypes[] = { "APE", NULL };
+
+// define plugin interface
+static DB_decoder_t plugin = {
+ .plugin.version_major = 0,
+ .plugin.version_minor = 1,
+ .plugin.type = DB_PLUGIN_DECODER,
+ .plugin.name = "Monkey's Audio decoder",
+ .plugin.descr = "Based on demac",
+ .plugin.author = "Alexey Yakovenko",
+ .plugin.email = "waker@users.sourceforge.net",
+ .plugin.website = "http://deadbeef.sf.net",
+/// .init = demac_init,
+/// .free = demac_free,
+/// .read_int16 = demac_read,
+/// .seek = demac_seek,
+/// .insert = demac_insert,
+ .exts = exts,
+ .id = "stddemac",
+ .filetypes = filetypes
+};
+
+DB_plugin_t *
+demac_load (DB_functions_t *api) {
+ deadbeef = api;
+ return DB_PLUGIN (&plugin);
+}
diff --git a/libdemac/SOURCES b/plugins/demac/libdemac/SOURCES
index 5a448237..5a448237 100644
--- a/libdemac/SOURCES
+++ b/plugins/demac/libdemac/SOURCES
diff --git a/libdemac/crc.c b/plugins/demac/libdemac/crc.c
index 30a49c8d..30a49c8d 100644
--- a/libdemac/crc.c
+++ b/plugins/demac/libdemac/crc.c
diff --git a/libdemac/decoder.c b/plugins/demac/libdemac/decoder.c
index d6327de2..d6327de2 100644
--- a/libdemac/decoder.c
+++ b/plugins/demac/libdemac/decoder.c
diff --git a/libdemac/decoder.h b/plugins/demac/libdemac/decoder.h
index e8810652..e8810652 100644
--- a/libdemac/decoder.h
+++ b/plugins/demac/libdemac/decoder.h
diff --git a/libdemac/demac.h b/plugins/demac/libdemac/demac.h
index 9a699a6e..9a699a6e 100644
--- a/libdemac/demac.h
+++ b/plugins/demac/libdemac/demac.h
diff --git a/libdemac/demac_config.h b/plugins/demac/libdemac/demac_config.h
index 8f3ad1e0..8f3ad1e0 100644
--- a/libdemac/demac_config.h
+++ b/plugins/demac/libdemac/demac_config.h
diff --git a/libdemac/entropy.c b/plugins/demac/libdemac/entropy.c
index df6bb7fd..df6bb7fd 100644
--- a/libdemac/entropy.c
+++ b/plugins/demac/libdemac/entropy.c
diff --git a/libdemac/entropy.h b/plugins/demac/libdemac/entropy.h
index ffef6211..ffef6211 100644
--- a/libdemac/entropy.h
+++ b/plugins/demac/libdemac/entropy.h
diff --git a/libdemac/filter.c b/plugins/demac/libdemac/filter.c
index 9f1abfb8..9f1abfb8 100644
--- a/libdemac/filter.c
+++ b/plugins/demac/libdemac/filter.c
diff --git a/libdemac/filter.h b/plugins/demac/libdemac/filter.h
index 946c76c5..946c76c5 100644
--- a/libdemac/filter.h
+++ b/plugins/demac/libdemac/filter.h
diff --git a/libdemac/filter_1280_15.c b/plugins/demac/libdemac/filter_1280_15.c
index d7916385..d7916385 100644
--- a/libdemac/filter_1280_15.c
+++ b/plugins/demac/libdemac/filter_1280_15.c
diff --git a/libdemac/filter_16_11.c b/plugins/demac/libdemac/filter_16_11.c
index b33e09eb..b33e09eb 100644
--- a/libdemac/filter_16_11.c
+++ b/plugins/demac/libdemac/filter_16_11.c
diff --git a/libdemac/filter_256_13.c b/plugins/demac/libdemac/filter_256_13.c
index 2dd9d06d..2dd9d06d 100644
--- a/libdemac/filter_256_13.c
+++ b/plugins/demac/libdemac/filter_256_13.c
diff --git a/libdemac/filter_32_10.c b/plugins/demac/libdemac/filter_32_10.c
index bdafb876..bdafb876 100644
--- a/libdemac/filter_32_10.c
+++ b/plugins/demac/libdemac/filter_32_10.c
diff --git a/libdemac/filter_64_11.c b/plugins/demac/libdemac/filter_64_11.c
index 26c85f19..26c85f19 100644
--- a/libdemac/filter_64_11.c
+++ b/plugins/demac/libdemac/filter_64_11.c
diff --git a/libdemac/parser.c b/plugins/demac/libdemac/parser.c
index 948640d7..948640d7 100644
--- a/libdemac/parser.c
+++ b/plugins/demac/libdemac/parser.c
diff --git a/libdemac/parser.h b/plugins/demac/libdemac/parser.h
index 0cfa665d..0cfa665d 100644
--- a/libdemac/parser.h
+++ b/plugins/demac/libdemac/parser.h
diff --git a/libdemac/predictor-arm.S b/plugins/demac/libdemac/predictor-arm.S
index bfb96738..bfb96738 100644
--- a/libdemac/predictor-arm.S
+++ b/plugins/demac/libdemac/predictor-arm.S
diff --git a/libdemac/predictor-cf.S b/plugins/demac/libdemac/predictor-cf.S
index 341e57f1..341e57f1 100644
--- a/libdemac/predictor-cf.S
+++ b/plugins/demac/libdemac/predictor-cf.S
diff --git a/libdemac/predictor.c b/plugins/demac/libdemac/predictor.c
index 7d914b5f..7d914b5f 100644
--- a/libdemac/predictor.c
+++ b/plugins/demac/libdemac/predictor.c
diff --git a/libdemac/predictor.h b/plugins/demac/libdemac/predictor.h
index ccf2b39b..ccf2b39b 100644
--- a/libdemac/predictor.h
+++ b/plugins/demac/libdemac/predictor.h
diff --git a/libdemac/vector_math16_armv5te.h b/plugins/demac/libdemac/vector_math16_armv5te.h
index 81a5cb6e..81a5cb6e 100644
--- a/libdemac/vector_math16_armv5te.h
+++ b/plugins/demac/libdemac/vector_math16_armv5te.h
diff --git a/libdemac/vector_math16_armv6.h b/plugins/demac/libdemac/vector_math16_armv6.h
index f6505f42..f6505f42 100644
--- a/libdemac/vector_math16_armv6.h
+++ b/plugins/demac/libdemac/vector_math16_armv6.h
diff --git a/libdemac/vector_math16_cf.h b/plugins/demac/libdemac/vector_math16_cf.h
index e51767b8..e51767b8 100644
--- a/libdemac/vector_math16_cf.h
+++ b/plugins/demac/libdemac/vector_math16_cf.h
diff --git a/libdemac/vector_math32_armv4.h b/plugins/demac/libdemac/vector_math32_armv4.h
index 47bc5e94..47bc5e94 100644
--- a/libdemac/vector_math32_armv4.h
+++ b/plugins/demac/libdemac/vector_math32_armv4.h
diff --git a/libdemac/vector_math_generic.h b/plugins/demac/libdemac/vector_math_generic.h
index b2dab1e2..b2dab1e2 100644
--- a/libdemac/vector_math_generic.h
+++ b/plugins/demac/libdemac/vector_math_generic.h