summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac2
-rw-r--r--deadbeef.h16
-rw-r--r--plugins/gtkui/plcommon.c6
-rw-r--r--plugins/lastfm/lastfm.c2
-rw-r--r--plugins/shellexec/shellexec.c2
5 files changed, 14 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 5b43f27c..59a595dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,7 +84,7 @@ AC_ARG_ENABLE(cdda, [ --disable-cdda disable CD-Audio plugin (defa
AC_ARG_ENABLE(gme, [ --disable-gme disable Game Music Emu plugin for NSF, AY, etc (default: enabled)], [enable_gme=$enableval], [enable_gme=yes])
AC_ARG_ENABLE(dumb, [ --disable-dumb disable D.U.M.B. plugin for MOD, S3M and other tracker formats (default: enabled)], [enable_dumb=$enableval], [enable_dumb=yes])
AC_ARG_ENABLE(notify, [ --disable-notify disable notification-daemon support plugin (default: enabled)], [enable_notify=$enableval], [enable_notify=yes])
-AC_ARG_ENABLE(shellexec, [ --disable-notify disable notification-daemon support plugin (default: enabled)], [enable_notify=$enableval], [enable_notify=yes])
+AC_ARG_ENABLE(shellexec, [ --disable-shellexec disable shell commands plugin (default: enabled)], [enable_shellexec=$enableval], [enable_shellexec=yes])
dnl AC_ARG_ENABLE(emidi, [ --disable-emidi disable emidi plugin (default: enabled)], [enable_emidi=$enableval], [enable_emidi=yes])
AC_ARG_ENABLE(musepack, [ --disable-musepack disable musepack plugin (default: enabled)], [enable_musepack=$enableval], [enable_musepack=yes])
AC_ARG_ENABLE(wildmidi, [ --disable-wildmidi disable wildmidi plugin (default: enabled)], [enable_wildmidi=$enableval], [enable_wildmidi=yes])
diff --git a/deadbeef.h b/deadbeef.h
index 5bf8b003..d6d9caaa 100644
--- a/deadbeef.h
+++ b/deadbeef.h
@@ -532,14 +532,14 @@ enum {
typedef struct DB_plugin_action_s {
const char *title;
- unsigned int flags;
- /*
- Function called when user activates menu item
- @it - pointer to selected playitem for single-track action,
- to first playitem for multiple-track action,
- or NULL for common action
- @data - opaque pointer
- */
+ uint32_t flags;
+ /**
+ * Function called when user activates menu item
+ * @it - pointer to selected playitem for single-track action,
+ * to first playitem for multiple-track action,
+ * or NULL for common action
+ * @data - opaque pointer
+ */
int (*callback) (DB_playItem_t *it, void *data);
void *data;
diff --git a/plugins/gtkui/plcommon.c b/plugins/gtkui/plcommon.c
index a24cb935..9f5b32df 100644
--- a/plugins/gtkui/plcommon.c
+++ b/plugins/gtkui/plcommon.c
@@ -350,8 +350,6 @@ void
actionitem_activate (GtkMenuItem *menuitem,
DB_plugin_action_t *action)
{
- DB_playItem_t *it = deadbeef->pl_get_first (PL_MAIN);
-
// Plugin can handle all tracks by itself
if (action->flags & DB_ACTION_CAN_MULTIPLE_TRACKS)
{
@@ -369,7 +367,8 @@ actionitem_activate (GtkMenuItem *menuitem,
return;
}
- //We end up here if plugin won't traverse tracks and we have to do it for him
+ //We end up here if plugin won't traverse tracks and we have to do it ourselves
+ DB_playItem_t *it = deadbeef->pl_get_first (PL_MAIN);
while (it) {
if (deadbeef->pl_is_selected (it))
action->callback (it, action->data);
@@ -377,6 +376,7 @@ actionitem_activate (GtkMenuItem *menuitem,
deadbeef->pl_item_unref (it);
it = next;
}
+ deadbeef->pl_item_unref (it);
}
void
diff --git a/plugins/lastfm/lastfm.c b/plugins/lastfm/lastfm.c
index 1773abd6..82b2db91 100644
--- a/plugins/lastfm/lastfm.c
+++ b/plugins/lastfm/lastfm.c
@@ -843,7 +843,7 @@ lfm_action_lookup (DB_playItem_t *it, void *data)
return 0;
char *command = NULL;
- if (-1 == asprintf (&command, "xdg-open http://www.last.fm/music/%s/_/%s", eartist, etitle))
+ if (-1 == asprintf (&command, "xdg-open 'http://www.last.fm/music/%s/_/%s'", eartist, etitle))
return 0;
system (command);
free (command);
diff --git a/plugins/shellexec/shellexec.c b/plugins/shellexec/shellexec.c
index f576ca9b..9141bf92 100644
--- a/plugins/shellexec/shellexec.c
+++ b/plugins/shellexec/shellexec.c
@@ -1,6 +1,6 @@
/*
Shellexec plugin for DeaDBeeF
- Copyright (C) 2009 Viktor Semykin <thesame.ml@gmail.com>
+ Copyright (C) 2010 Viktor Semykin <thesame.ml@gmail.com>
This program is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by