summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README1
-rw-r--r--configure.ac7
2 files changed, 6 insertions, 2 deletions
diff --git a/README b/README
index 94c99daa..165ef852 100644
--- a/README
+++ b/README
@@ -48,7 +48,6 @@ most of them are optional, which means deadbeef will build and run without them,
zlib: for Audio Overload plugin (psf, psf2, etc), GME (for vgz)
libzip: for vfs_zip plugin
yasm: required to build assembly portions of ffap plugin on supported platforms (x86, x86_64)
- gtkglext: for gtkui opengl support
actual package names for your Linux distribution may vary.
diff --git a/configure.ac b/configure.ac
index 0a3e2050..1cf6f08a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -424,9 +424,14 @@ AS_IF([test "${enable_hotkeys}" != "no"], [
AS_IF([test "${HAVE_XLIB_H}" = "yes"], [
HOTKEYS_LIBS="-lX11"
AC_SUBST(HOTKEYS_LIBS)
+ HAVE_HOTKEYS=yes
])
])
-HAVE_HOTKEYS=yes
+
+dnl no support for global hotkeys on osx, but plugin will work anyway
+AS_IF([test "${OS_OSX}" = "yes"], [
+ HAVE_HOTKEYS=yes
+])
dnl *** OSS output (partly stolen from audacious)
AS_IF([test "${enable_oss}" != "no"], [