summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--PORTABLE_VERSION2
-rw-r--r--configure.ac6
-rw-r--r--plugins/artwork/Makefile.am1
3 files changed, 7 insertions, 2 deletions
diff --git a/PORTABLE_VERSION b/PORTABLE_VERSION
index 8b80fc2e..1ccaca80 100644
--- a/PORTABLE_VERSION
+++ b/PORTABLE_VERSION
@@ -1 +1 @@
-0.5.6-rc2
+0.5.6-rc3
diff --git a/configure.ac b/configure.ac
index 884b0171..30c811c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([deadbeef], [devel])
+AC_INIT([deadbeef], [0.5.6-rc3])
AC_CONFIG_HEADER(config.h)
@@ -450,9 +450,13 @@ if test "x$enable_artwork" != "xno" ; then
if test "x$enable_staticlink" != "xno" ; then
HAVE_JPEG=yes
JPEG_DEPS_LIBS="../../$LIB/lib/libjpeg.a"
+ JPEG_DEPS_CFLAGS="-I../../$LIB/include"
+ AC_SUBST(JPEG_DEPS_CFLAGS)
AC_SUBST(JPEG_DEPS_LIBS)
HAVE_PNG=yes
+ PNG_DEPS_CFLAGS="-I../../$LIB/include/libpng15"
PNG_DEPS_LIBS="../../$LIB/lib/libpng.a ../../$LIB/lib/libz.a"
+ AC_SUBST(PNG_DEPS_CFLAGS)
AC_SUBST(PNG_DEPS_LIBS)
HAVE_IMLIB2=no
else
diff --git a/plugins/artwork/Makefile.am b/plugins/artwork/Makefile.am
index 74155a1c..dc46f7d9 100644
--- a/plugins/artwork/Makefile.am
+++ b/plugins/artwork/Makefile.am
@@ -10,6 +10,7 @@ ARTWORK_DEPS=$(IMLIB2_DEPS_LIBS)
ARTWORK_CFLAGS=-DUSE_IMLIB2
else
ARTWORK_DEPS=$(JPEG_DEPS_LIBS) $(PNG_DEPS_LIBS)
+ARTWORK_CFLAGS=$(JPEG_DEPS_CFLAGS) $(PNG_DEPS_CFLAGS)
endif
if HAVE_FLAC