summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ChangeLog18
-rw-r--r--configure.ac2
-rw-r--r--deadbeef.h3
-rw-r--r--web/index.html47
4 files changed, 57 insertions, 13 deletions
diff --git a/ChangeLog b/ChangeLog
index 0e51d804..95207794 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,13 +1,16 @@
version 0.3.2
all GTK+ UI code is now in plugin
+ improved main menu layout in GTK UI
numerous memory and cpu optimizations
fully editable/scriptable columns with sorting
native look and feel of playlist widget
- selection is synchronous between main window and search window
- plugins got GUI configuration
+ selection is synchronized between main window and search window
+ keyboard navigation in search window
+ plugins got basic GUI configuration
much smoother seekbar
compatible with more GTK theme engines
improved restore window geometry after minimizing to system tray
+ search window geometry is now saved and restored between sessions
flexible nowplaying querying support via command line
ALSA code moved to plugin
new "nullout" output plugin - good for testing, and as basis for new plugins
@@ -20,20 +23,15 @@ version 0.3.2
vtx plugin using libayemu
adplug plugin - cmf, rol, hsc, etc (including adlib S3Ms)
fixed cuesheet support in mp3 and ogg plugins
- fixed building for i686 architectures w/o sse2 support
- fixed sse2 code issues in ape plugin
- ported 24-bit ape support from rockbox
+ fixed sse2 issues on i686 architecture
+ added 24-bit ape support (thanks to Rockbox project)
added support for custom scrobbler url to last.fm plugin (e.g. libre.fm)
added Play Queue funtionality to playlist (context menu)
- fixed lots of bugs in command line processing
- improved main menu in GTK UI
added average/approximate bitrate display to statusbar
new "cursor follows playback" feature
new "stop after current track" feature
- keyboard navigation in search window
- search window geometry is now saved and restored between sessions
.dbpl extension is auto-added when saving playlist
- better handling of http streams
+ improved robustness in http code (handling connection problems, etc)
version 0.3.1
improved header widget drawing and gtkengines compatibility
diff --git a/configure.ac b/configure.ac
index 844d45a0..972009ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@ AC_INIT
AC_CONFIG_HEADER(config.h)
PACKAGE="deadbeef"
-VERSION="0.3.2-dev"
+VERSION="0.3.2"
AM_INIT_AUTOMAKE($PACKAGE,$VERSION)
diff --git a/deadbeef.h b/deadbeef.h
index c656a39e..df52223e 100644
--- a/deadbeef.h
+++ b/deadbeef.h
@@ -53,13 +53,14 @@ extern "C" {
// DON'T release plugins without DB_PLUGIN_SET_API_VERSION
// api version history:
+// 0.5 -- deadbeef-0.3.2
// 0.4 -- deadbeef-0.3.0
// 0.3 -- deadbeef-0.2.3.2
// 0.2 -- deadbeef-0.2.3
// 0.1 -- deadbeef-0.2.0
#define DB_API_VERSION_MAJOR 0
-#define DB_API_VERSION_MINOR 4
+#define DB_API_VERSION_MINOR 5
#define DB_PLUGIN_SET_API_VERSION\
.plugin.api_vmajor = DB_API_VERSION_MAJOR,\
diff --git a/web/index.html b/web/index.html
index 2863a8ee..27264350 100644
--- a/web/index.html
+++ b/web/index.html
@@ -55,6 +55,48 @@
<p><a href="#download">get it!</a></p>
<p>Changelog since 0.3.0</p>
<ul>
+ <li>all GTK+ UI code is now in plugin</li>
+ <li>improved main menu layout in GTK UI</li>
+ <li>numerous memory and cpu optimizations</li>
+ <li>fully editable/scriptable columns with sorting</li>
+ <li>native look and feel of playlist widget</li>
+ <li>selection is synchronized between main window and search window</li>
+ <li>keyboard navigation in search window</li>
+ <li>plugins got basic GUI configuration</li>
+ <li>much smoother seekbar</li>
+ <li>compatible with more GTK theme engines</li>
+ <li>improved restore window geometry after minimizing to system tray</li>
+ <li>search window geometry is now saved and restored between sessions</li>
+ <li>flexible nowplaying querying support via command line</li>
+ <li>ALSA code moved to plugin</li>
+ <li>new "nullout" output plugin - good for testing, and as basis for new plugins</li>
+ <li>added template .c file (with comments) for making new decoder plugins</li>
+ <li>updated id3v2 and apev2 parsers to support more metadata types</li>
+ <li>id3v2.2 parser now supports unsynchronization</li>
+ <li>metadata viewer accessible from context menu</li>
+ <li>flac plugin now plays "oga" files (flac in ogg container)</li>
+ <li>ffmpeg plugin, adds formats: m4a (aac,alac), mpc/mp+/mpp, wma, shn, oma, ac3, vqf</li>
+ <li>vtx plugin using libayemu</li>
+ <li>adplug plugin - cmf, rol, hsc, etc (including adlib S3Ms)</li>
+ <li>fixed cuesheet support in mp3 and ogg plugins</li>
+ <li>fixed sse2 issues on i686 architecture</li>
+ <li>added 24-bit ape support (thanks to Rockbox project)</li>
+ <li>added support for custom scrobbler url to last.fm plugin (e.g. libre.fm)</li>
+ <li>added Play Queue funtionality to playlist (context menu)</li>
+ <li>added average/approximate bitrate display to statusbar</li>
+ <li>new "cursor follows playback" feature</li>
+ <li>new "stop after current track" feature</li>
+ <li>.dbpl extension is auto-added when saving playlist</li>
+ <li>improved robustness in http code (handling connection problems, etc)</li>
+ </ul>
+</div>
+
+<h2>release 0.3.1 is out</h2>
+<div class="post">
+ <p class="date">2009/11/29</p>
+ <p><a href="#download">get it!</a></p>
+ <p>Changelog since 0.3.0</p>
+ <ul>
<li>improved header widget drawing and gtkengines compatibility</li>
<li>fixed vfs_curl to fetch content size properly again</li>
<li>fixed rare memory leak bug in seekbar drawing</li>
@@ -346,9 +388,12 @@ implemented basic session management, window size/position, volume, playmode are
</pre>
<h1 id="download">Download</h1>
-<h2>Latest version 0.3.1:</h2>
+<h2>Latest version 0.3.2:</h2>
<p>official Arch Linux PKGBUILD: <a href="http://aur.archlinux.org/packages.php?ID=29497">here</a></p>
<p>if you have yaourt, you can simply do yaourt -S deadbeef</p>
+<p>source code for version 0.3.2 <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-0.3.2.tar.gz/download">deadbeef-0.3.2.tar.gz</a></p>
+<p>or <a href="http://sourceforge.net/projects/deadbeef/files/">browse all files</a></p>
+<h2>version 0.3.1:</h2>
<p>source code for version 0.3.1 <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-0.3.1.tar.gz/download">deadbeef-0.3.1.tar.gz</a></p>
<p>or <a href="http://sourceforge.net/projects/deadbeef/files/">browse all files</a></p>
<p><b>unsupported</b> live gentoo ebuild from <a href="mailto:tonn.post@gmail.com">tonn</a>: <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-9999.ebuild/download">deadbeef-9999.ebuild</a></p>