summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--plugins/adplug/adplug-db.cpp12
-rw-r--r--plugins/gme/cgme.c12
-rw-r--r--plugins/sid/csid.cpp14
-rw-r--r--plugins/supereq/Equ.cpp12
-rw-r--r--tools/pluginfo/Makefile4
5 files changed, 2 insertions, 52 deletions
diff --git a/plugins/adplug/adplug-db.cpp b/plugins/adplug/adplug-db.cpp
index 17f52ccf..45cc6421 100644
--- a/plugins/adplug/adplug-db.cpp
+++ b/plugins/adplug/adplug-db.cpp
@@ -33,18 +33,6 @@
//#define trace(...) { fprintf (stderr, __VA_ARGS__); }
#define trace(fmt,...)
-int _Unwind_Resume_or_Rethrow;
-int _Unwind_RaiseException;
-int _Unwind_GetLanguageSpecificData;
-int _Unwind_Resume;
-int _Unwind_DeleteException;
-int _Unwind_GetTextRelBase;
-int _Unwind_SetIP;
-int _Unwind_GetDataRelBase;
-int _Unwind_GetRegionStart;
-int _Unwind_SetGR;
-int _Unwind_GetIPInfo;
-
extern "C" {
extern DB_decoder_t adplug_plugin;
diff --git a/plugins/gme/cgme.c b/plugins/gme/cgme.c
index e04d1bf7..a6452034 100644
--- a/plugins/gme/cgme.c
+++ b/plugins/gme/cgme.c
@@ -23,18 +23,6 @@
#include <zlib.h>
#include "../../deadbeef.h"
-int _Unwind_Resume_or_Rethrow;
-int _Unwind_RaiseException;
-int _Unwind_GetLanguageSpecificData;
-int _Unwind_Resume;
-int _Unwind_DeleteException;
-int _Unwind_GetTextRelBase;
-int _Unwind_SetIP;
-int _Unwind_GetDataRelBase;
-int _Unwind_GetRegionStart;
-int _Unwind_SetGR;
-int _Unwind_GetIPInfo;
-
//#define trace(...) { fprintf(stderr, __VA_ARGS__); }
#define trace(fmt,...)
diff --git a/plugins/sid/csid.cpp b/plugins/sid/csid.cpp
index af258f34..5eb717b6 100644
--- a/plugins/sid/csid.cpp
+++ b/plugins/sid/csid.cpp
@@ -30,20 +30,6 @@
#include "../../deadbeef.h"
#include "csid.h"
-#ifndef ANDROID
-int _Unwind_Resume_or_Rethrow;
-int _Unwind_RaiseException;
-int _Unwind_GetLanguageSpecificData;
-int _Unwind_Resume;
-int _Unwind_DeleteException;
-int _Unwind_GetTextRelBase;
-int _Unwind_SetIP;
-int _Unwind_GetDataRelBase;
-int _Unwind_GetRegionStart;
-int _Unwind_SetGR;
-int _Unwind_GetIPInfo;
-#endif
-
extern DB_decoder_t sid_plugin;
//#define trace(...) { fprintf(stderr, __VA_ARGS__); }
diff --git a/plugins/supereq/Equ.cpp b/plugins/supereq/Equ.cpp
index 49413ab2..afa5522e 100644
--- a/plugins/supereq/Equ.cpp
+++ b/plugins/supereq/Equ.cpp
@@ -24,18 +24,6 @@
#include "paramlist.hpp"
#include "Equ.h"
-int _Unwind_Resume_or_Rethrow;
-int _Unwind_RaiseException;
-int _Unwind_GetLanguageSpecificData;
-int _Unwind_Resume;
-int _Unwind_DeleteException;
-int _Unwind_GetTextRelBase;
-int _Unwind_SetIP;
-int _Unwind_GetDataRelBase;
-int _Unwind_GetRegionStart;
-int _Unwind_SetGR;
-int _Unwind_GetIPInfo;
-
#ifdef USE_OOURA
extern "C" void rdft(int, int, REAL *, int *, REAL *);
void rfft(int n,int isign,REAL *x)
diff --git a/tools/pluginfo/Makefile b/tools/pluginfo/Makefile
index e8ec4e29..84c47400 100644
--- a/tools/pluginfo/Makefile
+++ b/tools/pluginfo/Makefile
@@ -3,8 +3,8 @@ CFLAGS=-Wall
LDFLAGS=-lpthread -ldl -lm
all:
- mkdir x86_64
- mkdir i686
+ mkdir -p x86_64
+ mkdir -p i686
$(CC) -m32 $(CFLAGS) pluginfo.c $(LDFLAGS) -o i686/pluginfo
$(CC) -m64 $(CFLAGS) pluginfo.c $(LDFLAGS) -o x86_64/pluginfo