summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--conf.c3
-rw-r--r--configure.ac1
-rw-r--r--plugins/artwork/artwork.c3
-rw-r--r--plugins/cdda/cdda.c3
-rw-r--r--plugins/converter/converter.c3
-rw-r--r--plugins/converter/convgui.c3
6 files changed, 16 insertions, 0 deletions
diff --git a/conf.c b/conf.c
index eff15de5..9b2a75da 100644
--- a/conf.c
+++ b/conf.c
@@ -25,6 +25,9 @@
#include <inttypes.h>
#include <errno.h>
#include <unistd.h>
+#if HAVE_SYS_CDEFS_H
+#include <sys/cdefs.h>
+#endif
#if HAVE_SYS_SYSLIMITS_H
#include <sys/syslimits.h>
#endif
diff --git a/configure.ac b/configure.ac
index 781b0a7c..57914b28 100644
--- a/configure.ac
+++ b/configure.ac
@@ -131,6 +131,7 @@ dnl check for seperate alloca.h (OpenIndiana)
AC_CHECK_HEADER([alloca.h],[],[alloca.h not found.])
dnl check for syslimits.h (BSD)
AC_CHECK_HEADERS([sys/syslimits.h])
+AC_CHECK_HEADERS([sys/cdefs.h])
if test "x$enable_portable" != "xno" && test "x$enable_staticlink" != "xno" ; then
AC_DEFINE_UNQUOTED([PORTABLE], [1], [Define if building portable version])
diff --git a/plugins/artwork/artwork.c b/plugins/artwork/artwork.c
index 8f60455d..54f1f34a 100644
--- a/plugins/artwork/artwork.c
+++ b/plugins/artwork/artwork.c
@@ -10,6 +10,9 @@
#include <unistd.h>
#include <fnmatch.h>
#include <inttypes.h>
+#if HAVE_SYS_CDEFS_H
+#include <sys/cdefs.h>
+#endif
#if HAVE_SYS_SYSLIMITS_H
#include <sys/syslimits.h>
#endif
diff --git a/plugins/cdda/cdda.c b/plugins/cdda/cdda.c
index 9813b2a5..d970e4fe 100644
--- a/plugins/cdda/cdda.c
+++ b/plugins/cdda/cdda.c
@@ -26,6 +26,9 @@
#include <string.h>
#include <assert.h>
#include <sys/types.h>
+#if HAVE_SYS_CDEFS_H
+#include <sys/cdefs.h>
+#endif
#if HAVE_SYS_SYSLIMITS_H
#include <sys/syslimits.h>
#endif
diff --git a/plugins/converter/converter.c b/plugins/converter/converter.c
index 956e4586..72a5ddf5 100644
--- a/plugins/converter/converter.c
+++ b/plugins/converter/converter.c
@@ -19,6 +19,9 @@
#ifdef HAVE_CONFIG_H
# include "../../config.h"
#endif
+#if HAVE_SYS_CDEFS_H
+#include <sys/cdefs.h>
+#endif
#if HAVE_SYS_SYSLIMITS_H
#include <sys/syslimits.h>
#endif
diff --git a/plugins/converter/convgui.c b/plugins/converter/convgui.c
index 712c6f24..9c65fb9c 100644
--- a/plugins/converter/convgui.c
+++ b/plugins/converter/convgui.c
@@ -19,6 +19,9 @@
#ifdef HAVE_CONFIG_H
# include "../../config.h"
#endif
+#if HAVE_SYS_CDEFS_H
+#include <sys/cdefs.h>
+#endif
#if HAVE_SYS_SYSLIMITS_H
#include <sys/syslimits.h>
#endif