summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--configure.ac2
-rw-r--r--plugins/ao/Makefile3
-rwxr-xr-xscripts/portable_build.sh4
3 files changed, 4 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index ea407a50..f1e47909 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-AC_INIT([deadbeef], [0.5.0-beta2])
+AC_INIT([deadbeef], [devel])
AC_CONFIG_HEADER(config.h)
diff --git a/plugins/ao/Makefile b/plugins/ao/Makefile
index 890c0010..df3b9fd3 100644
--- a/plugins/ao/Makefile
+++ b/plugins/ao/Makefile
@@ -2,8 +2,7 @@ OUT=ao.so
CC=gcc
-#ZLIB_LIBS?=-lz
-ZLIB_LIBS=../../lib-x86-32/libz.a
+ZLIB_LIBS?=-lz
CFLAGS?=-O2 -fomit-frame-pointer
CFLAGS+=-Wall -fPIC -DPATH_MAX=1024 -DHAS_PSXCPU=1 -I../.. -I./ -Ieng_ssf -Ieng_qsf -Ieng_dsf
diff --git a/scripts/portable_build.sh b/scripts/portable_build.sh
index 412db5fa..c3e396fc 100755
--- a/scripts/portable_build.sh
+++ b/scripts/portable_build.sh
@@ -12,7 +12,7 @@ sed -i 's/-lstdc++ -lm -lgcc_s -lc -lgcc_s/-lm -lc/g' libtool
make clean
make -j9
-#ZLIB_LIBS="$ORIGIN/lib-x86-32/libz.a"
+ZLIB_LIBS="$ORIGIN/lib-x86-32/libz.a"
CFLAGS="-I$ORIGIN/lib-x86-32/include"
for i in shn dumb ao ; do
@@ -20,7 +20,7 @@ for i in shn dumb ao ; do
cd $ORIGIN/plugins/$i
make clean
echo making $ORIGIN/plugins/$i
- make -j8 STATIC_CFLAGS="$CFLAGS" CC=$CC CXX=$CXX
+ make -j8 STATIC_CFLAGS="$CFLAGS" CC=$CC CXX=$CXX ZLIB_LIBS=$ZLIB_LIBS
done
cd $ORIGIN