summaryrefslogtreecommitdiff
path: root/web
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-12 21:46:13 +0200
committerGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-12 21:46:13 +0200
commit6f349fb3d51c3992fcb6e336cac992b0153e7bc9 (patch)
tree52542f2fd672704fa11228c721a27163dab3f60a /web
parent5dfa6e82805e5fd43957d0415a9d62e6452649d7 (diff)
updated website
Diffstat (limited to 'web')
-rw-r--r--web/index.html96
1 files changed, 80 insertions, 16 deletions
diff --git a/web/index.html b/web/index.html
index cdd10f7e..b442ce2a 100644
--- a/web/index.html
+++ b/web/index.html
@@ -2,20 +2,63 @@
<head>
<title>DeaDBeeF - Ultimate Music Player For GNU/Linux</title>
</head>
+<style>
+ body {
+ background-color: #eeeeee;
+ }
+ #header {
+ margin: 0;
+ padding: 0;
+ }
+ #header li {
+ display: inline;
+ margin-left: 1em;
+ }
+ h1 {
+ font-variant: small-caps;
+ }
+ .post {
+ margin-left: 2em;
+ background-color: #d7d7d7;
+ padding: 1em;
+ -moz-border-radius: 3;
+ border-radius: 3;
+ border-width: 1;
+ border-color: #cccccc;
+ }
+ .post p {
+ padding: 0;
+ margin: 0;
+ }
+ p.date {
+ font-size: 80%;
+ margin-bottom: 0.5em;
+ }
+</style>
<body>
-<a href="#news">News</a><br/>
-<a href="#about">About</a><br/>
-<a href="#license">Copying</a><br/>
-<a href="#download">Download</a><br/>
-<a href="#bugs">Reporting Bugs And Requesting Features</a><br/>
-<a href="#developers">Developer Information</a><br/>
-<a href="#contacts">Contacts</a><br/>
-<a href="#screenshots">Screenshots</a><br/>
+<ul id='header'>
+ <li><a href="#news">News</a></li>
+ <li><a href="#about">About</a></li>
+ <li><a href="#license">Copying</a></li>
+ <li><a href="#download">Download</a></li>
+ <li><a href="#bugs">Reporting Bugs</a></li>
+ <li><a href="#developers">Developer Information</a></li>
+ <li><a href="#contacts">Contacts</a></li>
+ <li><a href="#screenshots">Screenshots</a></li>
+</ul>
<h1 id="news">News</h1>
+<h2>updated debian packages</h2>
+<div class="post">
+<p class="date">2009/09/12</p>
+<p>debian packages for 0.2.0 are available, thanx to Alexey Smirnov</p>
+<p><a href='#download'>download</a></p>
+</div>
+
<h2>deadbeef-0.2.0 is out!</h2>
-<p>2009/09/08</p>
+<div class='post'>
+<p class='date'>2009/09/08</p>
<p><a href="#download">get it!</a></p>
<p>Changelog since 0.1.1:</p>
<p><i>please note this changelog is what most users would notice. actual changelog is 10 times bigger, and is not worth reading. i don't want to count each of 1000 bugfixes here.</i></p>
@@ -46,9 +89,11 @@
<li>column sizes are now saved between sessions</li>
<li>select multiple folders in "add folder(s)" dialog</li>
</ul>
+</div>
<h2>tag loading/recoding policy</h2>
-<p>2009/09/06</p>
+<div class='post'>
+<p class='date'>2009/09/06</p>
<ul>
<li>id3v1 loader will always try to detect cp1251.</li>
<li>id3v2 loader will only try to detect cp1251 if encoding is not specified.</li>
@@ -61,9 +106,11 @@
<li>8bit charsets other than cp1251 and iso8859-1 (like koi8-r) are not
supported now, but might be added in the future.</li>
</ul>
+</div>
<h2>APE support status</h2>
-<p>2009/09/01</p>
+<div class='post'>
+<p class='date'>2009/09/01</p>
<p>a lot of people are asking me about whether deadbeef is going to support APE (Monkey's Audio Codec) format.</p>
<p>indeed, support is already in plugins branch, and everyone brave enough can try it. it's not fully finished yet, but working.</p>
<p>unique feature of deadbeef is that it supports BOTH ape decoders available for linux: libmac (unofficial port of official sdk with crappy license), and libdemac (unofficial decoder licensed under GPL, developed by <a href="http://www.rockbox.org/">rockbox</a> people)</p>
@@ -75,24 +122,32 @@
<p>worst case i've seen until now was 40% cpu time on libdemac, while 20% cpu time on libmac (3GHz Xeon CPU, same .ape file with extreme compression)</p>
<p>that's it for now!</p>
<p>happy listening</p>
+</div>
<h2>One more Gentoo Ebuild</h2>
-<p>2009/08/31</h2>
+<div class='post'>
+<p class='date'>2009/08/31</h2>
<p><a href="mailto:tonn.post@gmail.com">Anton Novikov</a> sent another ebuild for GIT version of DeaDBeeF</p>
<p>as always, check <a href="#download">download section</a></p>
+</div>
<h2>Gentoo ebuild</h2>
-<p>2009/08/31</p>
+<div class='post'>
+<p class='date'>2009/08/31</p>
<p><a href="mailto:prodoomman@gmail.com">proDOOMman</a> sent nice ebuild for gentoo linux</p>
<p>check <a href="#download">download section</a></p>
+</div>
<h2>Slackware Packages</h2>
-<p>2009/08/30</p>
+<div class='post'>
+<p class='date'>2009/08/30</p>
<p><a href="mailto:sftp.mtuci@gmail.com">happy user</a> provided packages for Slackware 12.1 and 12.2</p>
<p>check <a href="#download">download section</a></p>
+</div>
<h2>release 0.1.1 is out!</h2>
-<p>2009/08/23</p>
+<div class='post'>
+<p class='date'>2009/08/23</p>
<p>changelog:</p>
<pre>
volume control now works on dB scale
@@ -111,20 +166,27 @@ fixed id3v2 unsynchronized frames reading
implemented basic session management, window size/position, volume, playmode are remembered across sessions
</pre>
<p><a href="#download">download</a> now!</p>
+</div>
<h2>Arch Linux PKGBUILD is available</h2>
+<div class='post'>
<p>yaourt -S deadbeef</p>
+</div>
<h2>GIT repository</h2>
+<div class='post'>
<p>i pushed my git repository to sf.net on Thu Aug 20 2009</p>
<p>git version has several bugfixes/improvements over alpha release, so feel free to use it.</p>
<p><pre>git clone git://deadbeef.git.sourceforge.net/gitroot/deadbeef/deadbeef</pre></p>
+</div>
<h2>Alpha released</h2>
+<div class='post'>
<p>first alpha release 0.1.0 just appened on Wed Aug 19 21:59:27 CEST 2009!</p>
<p>there was a report from a happy user that deadbeef won't compile with gtk&lt;=2.16.</p>
<p>fix is very easy, and will be available in next release, and in git head when i have time to prepare and push it</p>
<p>thanks for understanding and happy hacking!</p>
+</div>
<h1 id='about'>About</h1>
<p>DeaDBeeF (as in 0xDEADBEEF) is an audio player for GNU/Linux systems with X11.</p>
@@ -176,10 +238,12 @@ implemented basic session management, window size/position, volume, playmode are
<p>or <a href="http://sourceforge.net/projects/deadbeef/files/">browse all files</a></p>
<p><b>unsupported</b> slackware package for version 0.2.0 from <a href="mailto:sftp.mtuci@gmail.com">sftp.mtuci@gmail.com</a>:</p>
<p><a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-0.2.0-i686-slack12.2_1.tgz/download">i686 slackware 12.2</a></p>
+<p><b>unsupported</b> debian packages for version 0.2.0 from <a href="mailto:alexey.smirnov@gmx.com">Alexey Smirnov</a>:</p>
+<p><a href="http://sourceforge.net/projects/deadbeef/files/deadbeef_0.2-1_i386.deb/download">i386</a>, <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef_0.2-1_amd64.deb/download">x86_64</a>, <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-plugins-dev_0.2-1_all.deb/download">plugin sdk</a></p>
<p>note: i have nothing to do with these packages, nor can i test them. use at your own risk</p>
<h2>Old stuff</h2>
<p>source code for version 0.1.1 <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-0.1.1.tar.gz/download">deadbeef-0.1.1.tar.gz</a></p>
-<p><b>unsupported</b> debian packages for version 0.1.1 from <a href="mailto:alexey.smirnov@gmx.com">sceptic</a>:</p>
+<p><b>unsupported</b> debian packages for version 0.1.1 from <a href="mailto:alexey.smirnov@gmx.com">Alexey Smirnov</a>:</p>
<p><a href="http://sourceforge.net/projects/deadbeef/files/deadbeef_0.1.1-1_i386.deb/download">i386</a>, <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef_0.1.1-1_amd64.deb/download">x86_64</a></p>
<p><b>unsupported</b> slackware packages for version 0.1.1 from <a href="mailto:sftp.mtuci@gmail.com">sftp.mtuci@gmail.com</a>:</p>
<p><a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-0.1.1-i686-slack12.1-1.tgz/download">i386 slackware 12.1</a>, <a href="http://sourceforge.net/projects/deadbeef/files/deadbeef-0.1.1-i686-slack12.2-1.tgz/download">i386 slackware 12.2</a></p>