summaryrefslogtreecommitdiff
path: root/tools/apbuild/ctype.h
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2012-10-05 17:46:33 +0200
committerGravatar waker <wakeroid@gmail.com>2012-10-05 17:46:33 +0200
commitce2923c8f0cac7a563d1ecf22085ac62281c74d7 (patch)
tree20ce1a2fd0cebc36231882b011e34230778a1db9 /tools/apbuild/ctype.h
parent527ba48d8209a8e854c791d571106a5daf2fdd29 (diff)
parent708c8ba9f7aefe9f795c9c4eb30ab128f09c8b3d (diff)
Merge branch 'master' into devel
Conflicts: README configure.ac deadbeef.h plugins.c plugins/gtkui/Makefile.am plugins/gtkui/ddbcellrenderertextmultiline.c plugins/gtkui/ddblistview.c plugins/gtkui/deadbeef.glade plugins/gtkui/gtkui.c plugins/gtkui/interface.c plugins/gtkui/plcommon.c plugins/shellexec/shellexec.c plugins/supereq/Makefile.am
Diffstat (limited to 'tools/apbuild/ctype.h')
-rw-r--r--tools/apbuild/ctype.h10
1 files changed, 8 insertions, 2 deletions
diff --git a/tools/apbuild/ctype.h b/tools/apbuild/ctype.h
index 2db84cc1..ee93b991 100644
--- a/tools/apbuild/ctype.h
+++ b/tools/apbuild/ctype.h
@@ -76,9 +76,15 @@ extern __const unsigned short int *__ctype_b; /* Characteristics. */
extern __const __int32_t *__ctype_tolower; /* Case conversions. */
extern __const __int32_t *__ctype_toupper; /* Case conversions. */
+#if __x86_64__
+__asm__(".symver __ctype_b,__ctype_b@GLIBC_2.2.5");
+__asm__(".symver __ctype_tolower,__ctype_tolower@GLIBC_2.2.5");
+__asm__(".symver __ctype_toupper,__ctype_toupper@GLIBC_2.2.5");
+#else
__asm__(".symver __ctype_b,__ctype_b@GLIBC_2.0");
-__asm__(".symver __ctype_tolower,__ctype_tolower@GLIBC_2.0");
-__asm__(".symver __ctype_toupper,__ctype_toupper@GLIBC_2.0");
+__asm__(".symver __ctype_tolower,__ctype_tolower@GLIBC_2.2.5");
+__asm__(".symver __ctype_toupper,__ctype_toupper@GLIBC_2.2.5");
+#endif
#define __isctype(c, type) \
(__ctype_b[(int) (c)] & (unsigned short int) type)