summaryrefslogtreecommitdiff
path: root/streamer.h
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2012-10-19 17:42:18 +0200
committerGravatar waker <wakeroid@gmail.com>2012-10-19 17:42:18 +0200
commit9371c5953b51235388fb657fba288b9a99005ad1 (patch)
treec20e1f98d15ba90597f5fc5f44a144a763e784de /streamer.h
parent73a6c7eea6ccf48f0d2872997b93c6ee5b78fac4 (diff)
parentcf99fd6ea3cd728fa643e7d34e6edbf026f0feb5 (diff)
Merge branch 'master' into devel
Conflicts: configure.ac streamer.c streamer.h
Diffstat (limited to 'streamer.h')
-rw-r--r--streamer.h36
1 files changed, 24 insertions, 12 deletions
diff --git a/streamer.h b/streamer.h
index d3818240..aee63c35 100644
--- a/streamer.h
+++ b/streamer.h
@@ -1,19 +1,28 @@
/*
- DeaDBeeF - ultimate music player for GNU/Linux systems with X11
- Copyright (C) 2009-2012 Alexey Yakovenko <waker@users.sourceforge.net>
+ This file is part of Deadbeef Player source code
+ http://deadbeef.sourceforge.net
- This program is free software: you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation, either version 2 of the License, or
- (at your option) any later version.
+ streamer implementation
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
+ Copyright (C) 2009-2012 Alexey Yakovenko
- You should have received a copy of the GNU General Public License
- along with this program. If not, see <http://www.gnu.org/licenses/>.
+ This software is provided 'as-is', without any express or implied
+ warranty. In no event will the authors be held liable for any damages
+ arising from the use of this software.
+
+ Permission is granted to anyone to use this software for any purpose,
+ including commercial applications, and to alter it and redistribute it
+ freely, subject to the following restrictions:
+
+ 1. The origin of this software must not be misrepresented; you must not
+ claim that you wrote the original software. If you use this software
+ in a product, an acknowledgment in the product documentation would be
+ appreciated but is not required.
+ 2. Altered source versions must be plainly marked as such, and must not be
+ misrepresented as being the original software.
+ 3. This notice may not be removed or altered from any source distribution.
+
+ Alexey Yakovenko waker@users.sourceforge.net
*/
#ifndef __STREAMER_H
#define __STREAMER_H
@@ -133,4 +142,7 @@ streamer_notify_order_changed (int prev_order, int new_order);
void
audio_get_waveform_data (int type, float *data);
+void
+streamer_set_streamer_playlist (playlist_t *plt);
+
#endif // __STREAMER_H