summaryrefslogtreecommitdiff
path: root/scripts
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2012-10-19 17:42:18 +0200
committerGravatar waker <wakeroid@gmail.com>2012-10-19 17:42:18 +0200
commit9371c5953b51235388fb657fba288b9a99005ad1 (patch)
treec20e1f98d15ba90597f5fc5f44a144a763e784de /scripts
parent73a6c7eea6ccf48f0d2872997b93c6ee5b78fac4 (diff)
parentcf99fd6ea3cd728fa643e7d34e6edbf026f0feb5 (diff)
Merge branch 'master' into devel
Conflicts: configure.ac streamer.c streamer.h
Diffstat (limited to 'scripts')
-rwxr-xr-xscripts/portable_package_static.sh4
-rwxr-xr-xscripts/portable_postbuild.sh8
-rwxr-xr-xscripts/static_build.sh3
3 files changed, 13 insertions, 2 deletions
diff --git a/scripts/portable_package_static.sh b/scripts/portable_package_static.sh
index 1ad0c076..bbac7f1a 100755
--- a/scripts/portable_package_static.sh
+++ b/scripts/portable_package_static.sh
@@ -32,6 +32,7 @@ tar jcvf ../../portable_out/build/$OUTNAME\
$PLUGDIR/dca.so\
$PLUGDIR/ddb_gui_GTK2.fallback.so\
$PLUGDIR/ddb_gui_GTK2.so\
+ $PLUGDIR/ddb_gui_GTK3.so\
$PLUGDIR/ffap.so\
$PLUGDIR/ffmpeg.so\
$PLUGDIR/flac.so\
@@ -47,6 +48,7 @@ tar jcvf ../../portable_out/build/$OUTNAME\
$PLUGDIR/oss.so\
$PLUGDIR/shellexec.so\
$PLUGDIR/shellexecui_gtk2.so\
+ $PLUGDIR/shellexecui_gtk3.so\
$PLUGDIR/sid.so\
$PLUGDIR/sndfile.so\
$PLUGDIR/supereq.so\
@@ -62,10 +64,12 @@ tar jcvf ../../portable_out/build/$OUTNAME\
$PLUGDIR/ddb_dumb.so\
$PLUGDIR/converter.so\
$PLUGDIR/converter_gtk2.so\
+ $PLUGDIR/converter_gtk3.so\
$PLUGDIR/convpresets\
$PLUGDIR/pulse.so\
$PLUGDIR/dsp_libsrc.so\
$PLUGDIR/ddb_mono2stereo.so\
+ $PLUGDIR/alac.so\
$PIXMAPDIR\
$SRCDIR/locale
cd ../..
diff --git a/scripts/portable_postbuild.sh b/scripts/portable_postbuild.sh
index 45db6740..c1de99c7 100755
--- a/scripts/portable_postbuild.sh
+++ b/scripts/portable_postbuild.sh
@@ -18,7 +18,7 @@ cp ./deadbeef $OUTDIR
for i in nullout cdda flac alsa mpgmad hotkeys vtx \
ffap ffmpeg wavpack vorbis oss vfs_curl \
- lastfm sid adplug sndfile artwork \
+ lastfm sid adplug sndfile artwork alac \
supereq gme dumb notify musepack wildmidi \
tta dca aac mms shn ao shellexec shellexecui vfs_zip \
m3u converter pulse dsp_libsrc mono2stereo ; do
@@ -53,6 +53,12 @@ if [ -f ./plugins/gtkui/.libs/ddb_gui_GTK2.fallback.so ]; then
cp ./plugins/gtkui/.libs/ddb_gui_GTK2.fallback.so $PLUGDIR/
fi
+if [ -f ./plugins/gtkui/.libs/ddb_gui_GTK3.so ]; then
+ cp ./plugins/gtkui/.libs/ddb_gui_GTK3.so $PLUGDIR/
+else
+ echo ./plugins/gtkui/.libs/ddb_gui_GTK3.so not found
+fi
+
#pixmaps
for i in pause_16.png play_16.png noartwork.png buffering_16.png; do
diff --git a/scripts/static_build.sh b/scripts/static_build.sh
index 250b29e8..f46ec8aa 100755
--- a/scripts/static_build.sh
+++ b/scripts/static_build.sh
@@ -11,8 +11,9 @@ cd ../../
./autogen.sh
export APBUILD_STATIC_LIBGCC=1
-CC=$AP/apgcc CXX=$AP/apgcc ./configure --enable-staticlink --disable-artwork-imlib2 --prefix=/opt/deadbeef
+CC=$AP/apgcc CXX=$AP/apgcc ./configure --enable-staticlink --disable-artwork-imlib2 --enable-ffmpeg --prefix=/opt/deadbeef
sed -i 's/-lstdc++ -lm -lgcc_s -lc -lgcc_s/-lm -lc/g' libtool
+sed -i 's/hardcode_into_libs=yes/hardcode_into_libs=no/g' libtool
make clean
make DESTDIR=`pwd`/static/$ARCH/deadbeef-$VERSION -j8 install