summaryrefslogtreecommitdiff
path: root/plugins
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2012-04-13 19:26:20 +0200
committerGravatar waker <wakeroid@gmail.com>2012-04-13 19:26:20 +0200
commit1d8ea228d6fb841b00fc4fc57ee3872bc778b4a3 (patch)
treeaae2526abb4c3c239301dd291ecdfbd183b06fcc /plugins
parent8aafeeeaa5be31f6b04b59a8773f332f5ee7d14c (diff)
renamed Fftsg_fl.cpp to Fftsg_fl.c
Diffstat (limited to 'plugins')
-rw-r--r--plugins/supereq/Fftsg_fl.c (renamed from plugins/supereq/Fftsg_fl.cpp)3
-rw-r--r--plugins/supereq/Makefile.am2
2 files changed, 1 insertions, 4 deletions
diff --git a/plugins/supereq/Fftsg_fl.cpp b/plugins/supereq/Fftsg_fl.c
index 636f8b8a..d66ae896 100644
--- a/plugins/supereq/Fftsg_fl.cpp
+++ b/plugins/supereq/Fftsg_fl.c
@@ -285,8 +285,6 @@ Appendix :
w[] and ip[] are compatible with all routines.
*/
-extern "C" {
-
void cdft(int n, int isgn, REAL *a, int *ip, REAL *w)
{
void makewt(int nw, int *ip, REAL *w);
@@ -2650,4 +2648,3 @@ void dstsub(int n, REAL *a, int nc, REAL *c)
}
a[m] *= c[0];
}
-}
diff --git a/plugins/supereq/Makefile.am b/plugins/supereq/Makefile.am
index 4ce19ee5..af5572c6 100644
--- a/plugins/supereq/Makefile.am
+++ b/plugins/supereq/Makefile.am
@@ -1,7 +1,7 @@
if HAVE_SUPEREQ
supereqdir = $(libdir)/$(PACKAGE)
pkglib_LTLIBRARIES = supereq.la
-supereq_la_SOURCES = supereq.c Equ.cpp Equ.h Fftsg_fl.cpp paramlist.hpp
+supereq_la_SOURCES = supereq.c Equ.cpp Equ.h Fftsg_fl.c paramlist.hpp
#nsfft-1.00/simd/SIMDBaseUndiff.c\
#nsfft-1.00/simd/SIMDBase.c\