summaryrefslogtreecommitdiff
path: root/plugins
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2009-08-31 23:01:53 +0200
committerGravatar waker <wakeroid@gmail.com>2009-08-31 23:01:53 +0200
commit011624b9af820f54d3bdbb9dfcae985b0d5c8d7c (patch)
tree7ebd01a1cef3af3bd911433af44f883fe16e0b29 /plugins
parentcad9f623e684c39f210829363866991f76636596 (diff)
added libdemac
Diffstat (limited to 'plugins')
-rw-r--r--plugins/ape/Makefile.am2
-rw-r--r--plugins/ape/ape.c1
2 files changed, 2 insertions, 1 deletions
diff --git a/plugins/ape/Makefile.am b/plugins/ape/Makefile.am
index b7d0b805..07b43270 100644
--- a/plugins/ape/Makefile.am
+++ b/plugins/ape/Makefile.am
@@ -3,5 +3,5 @@ pkglib_LTLIBRARIES = ape.la
ape_la_SOURCES = ape.c apewrapper.cpp apewrapper.h
ape_la_LDFLAGS = -module
-ape_la_LIBADD = $(LDADD) $(APE_DEPS_LIBS) -lmac
+ape_la_LIBADD = $(LDADD) $(APE_LIBS)
AM_CFLAGS = $(APE_DEPS_CFLAGS) -std=c99
diff --git a/plugins/ape/ape.c b/plugins/ape/ape.c
index 175d1127..619d8f1c 100644
--- a/plugins/ape/ape.c
+++ b/plugins/ape/ape.c
@@ -46,6 +46,7 @@ static int
ape_init (DB_playItem_t *it) {
ape_dec = ape_decompress_create (it->fname);
if (!ape_dec) {
+ printf ("ape_decompress_create failed for file %s\n", it->fname);
return -1;
}
WAVEFORMATEX wfe;