summaryrefslogtreecommitdiff
path: root/plugins/vorbis/Makefile.am
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-05 14:50:22 +0200
committerGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-05 14:50:22 +0200
commit2e81b08e5877ef2ce4a7ca163eec552f5d72ed94 (patch)
treeb30eb09ad5beea55b9a24465fd21e87d553e080f /plugins/vorbis/Makefile.am
parent3d5c761881717162a0757300adc769b1e5097d7b (diff)
moved vorbis support to plugin ; some improvements in build system
Diffstat (limited to 'plugins/vorbis/Makefile.am')
-rw-r--r--plugins/vorbis/Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/plugins/vorbis/Makefile.am b/plugins/vorbis/Makefile.am
new file mode 100644
index 00000000..09b30479
--- /dev/null
+++ b/plugins/vorbis/Makefile.am
@@ -0,0 +1,7 @@
+vorbisdir = $(libdir)/$(PACKAGE)
+pkglib_LTLIBRARIES = vorbis.la
+vorbis_la_SOURCES = vorbis.c
+vorbis_la_LDFLAGS = -module
+
+vorbis_la_LIBADD = $(LDADD) $(VORBIS_LIBS)
+AM_CFLAGS = $(CFLAGS) -std=c99