summaryrefslogtreecommitdiff
path: root/plugins/supereq/Makefile.am
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2010-10-24 09:18:28 +0200
committerGravatar waker <wakeroid@gmail.com>2010-10-24 09:18:28 +0200
commit1165a25a0ac57d3bcaf29afc9a5537523d4b0a99 (patch)
tree17654dda88fa8c172d3db67e760eb6731478d939 /plugins/supereq/Makefile.am
parentaa7aaa4c2be4a27d858b582c338ba14a2aa72732 (diff)
adapted remaining cpp plugins to portable build
Diffstat (limited to 'plugins/supereq/Makefile.am')
-rw-r--r--plugins/supereq/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/plugins/supereq/Makefile.am b/plugins/supereq/Makefile.am
index 0fffd6d6..eecade68 100644
--- a/plugins/supereq/Makefile.am
+++ b/plugins/supereq/Makefile.am
@@ -3,7 +3,9 @@ supereqdir = $(libdir)/$(PACKAGE)
pkglib_LTLIBRARIES = supereq.la
supereq_la_SOURCES = supereq.c supereq.h Equ.cpp Fftsg_fl.cpp paramlist.hpp
-supereq_la_LDFLAGS = -module
+AM_CPPFLAGS = $(CXXFLAGS) -fno-exceptions -fno-rtti -nostdlib -fno-unwind-tables
+
+supereq_la_LDFLAGS = -module -nostdlib -lsupc++
supereq_la_LIBADD = $(LDADD)
AM_CFLAGS = -std=c99