summaryrefslogtreecommitdiff
path: root/plugins/shn
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2011-10-23 17:32:01 +0200
committerGravatar waker <wakeroid@gmail.com>2011-10-23 17:32:01 +0200
commit2d7bb0979b2e34403925a8e2903773f9c8ad8b8f (patch)
tree4c1cbd35b3f48a8b48fc1e1c098b21898b1e5bb6 /plugins/shn
parent0556a39f8a37da68f21772da896ebfdf15b6057d (diff)
readded DUMB, AOPSF and SHN plugins to tarball
Diffstat (limited to 'plugins/shn')
-rw-r--r--plugins/shn/Makefile23
-rw-r--r--plugins/shn/Makefile.am10
2 files changed, 10 insertions, 23 deletions
diff --git a/plugins/shn/Makefile b/plugins/shn/Makefile
deleted file mode 100644
index d76c8427..00000000
--- a/plugins/shn/Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
-OUT=ddb_shn.so
-
-CC?=gcc
-
-CFLAGS?=-I../..
-CFLAGS+=-Wall -fPIC -std=c99 -D_GNU_SOURCE -DHAVE_CONFIG_H -I.
-
-LDFLAGS+=-module -shared -lm
-
-SOURCES=array.c convert.c misc.c output.c seek.c shn.c shorten.c sulawalaw.c vario.c wave.c
-
-OBJECTS=$(SOURCES:.c=.o)
-
-all: $(SOURCES) $(OUT)
-
-$(OUT): $(OBJECTS)
- $(CC) $(LDFLAGS) $(OBJECTS) -o $@
-
-.c.o:
- $(CC) $(CFLAGS) $< -c -o $@
-
-clean:
- rm $(OBJECTS) $(OUT)
diff --git a/plugins/shn/Makefile.am b/plugins/shn/Makefile.am
new file mode 100644
index 00000000..acc597ef
--- /dev/null
+++ b/plugins/shn/Makefile.am
@@ -0,0 +1,10 @@
+if HAVE_SHN
+shndir = $(libdir)/$(PACKAGE)
+pkglib_LTLIBRARIES = ddb_shn.la
+ddb_shn_la_SOURCES = array.c convert.c misc.c output.c seek.c shn.c shn.h shorten.c shorten.h sulawalaw.c vario.c wave.c bitshift.h
+
+ddb_shn_la_LDFLAGS = -module
+
+ddb_shn_la_LIBADD = $(LDADD) -lm
+AM_CFLAGS = $(CFLAGS) -std=c99
+endif