summaryrefslogtreecommitdiff
path: root/plugins/shellexecui
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <waker@users.sourceforge.net>2014-03-09 12:26:36 +0100
committerGravatar Alexey Yakovenko <waker@users.sourceforge.net>2014-03-09 12:26:36 +0100
commitb6832fc06c87a2fd9c98dd5061466985dc612b67 (patch)
treeb5ece337333eb859f1ad89d8b7cee24b797829f0 /plugins/shellexecui
parentaafb296013538a7beddbe4749b66868cb84b0cea (diff)
gtk linking changes for static build
Diffstat (limited to 'plugins/shellexecui')
-rw-r--r--plugins/shellexecui/Makefile.am9
1 files changed, 0 insertions, 9 deletions
diff --git a/plugins/shellexecui/Makefile.am b/plugins/shellexecui/Makefile.am
index 52c596cd..22d84e57 100644
--- a/plugins/shellexecui/Makefile.am
+++ b/plugins/shellexecui/Makefile.am
@@ -34,18 +34,9 @@ endif
if HAVE_GTK3
shellexecui_gtk3_la_SOURCES = shellexecui.c interface.c support.c callbacks.c interface.h support.h callbacks.h
shellexecui_gtk3_la_LDFLAGS = -module -avoid-version
-if STATICLINK
-GTK_ROOT_300=@top_srcdir@/$(LIB)/gtk-3.0.0
-
-shellexecui_gtk3_la_LIBADD = $(LDADD) -L$(GTK_ROOT_300)/lib -lgtk-3 -lgdk-3 -latk-1.0 -lgio-2.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo-gobject -lpango-1.0 -lcairo -lgobject-2.0 -lglib-2.0 -lfreetype $(SM_LIBADD)
-
-shellexecui_gtk3_la_CFLAGS = -std=c99 -I$(GTK_ROOT_300)/include/gtk-3.0 -I$(GTK_ROOT_300)/include/pango-1.0 -I$(GTK_ROOT_300)/include/gio-unix-2.0/ -I$(GTK_ROOT_300)/include/atk-1.0 -I$(GTK_ROOT_300)/include/cairo -I$(GTK_ROOT_300)/include/gdk-pixbuf-2.0 -I$(GTK_ROOT_300)/include/freetype2 -I$(GTK_ROOT_300)/include/glib-2.0 -I$(GTK_ROOT_300)/lib/glib-2.0/include $(SM_CFLAGS)
-
-else
shellexecui_gtk3_la_LIBADD = $(LDADD) $(GTK3_DEPS_LIBS)
shellexecui_gtk3_la_CFLAGS = -std=c99 $(GTK3_DEPS_CFLAGS)
endif
-endif
endif