summaryrefslogtreecommitdiff
path: root/plugins/shellexecui
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <waker@users.sourceforge.net>2014-02-05 20:59:59 +0100
committerGravatar Alexey Yakovenko <waker@users.sourceforge.net>2014-02-05 20:59:59 +0100
commitb06812a7261467785f7fe3f537f010885cfa732f (patch)
treed69a09ac6647cd598bbbefb501b4cd10e211f2c0 /plugins/shellexecui
parentca77fa97d3f7a2f2f73e39031b87b3be819da93b (diff)
added -avoid-version to all makefiles
Diffstat (limited to 'plugins/shellexecui')
-rw-r--r--plugins/shellexecui/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/plugins/shellexecui/Makefile.am b/plugins/shellexecui/Makefile.am
index 4fb4e018..ee15f428 100644
--- a/plugins/shellexecui/Makefile.am
+++ b/plugins/shellexecui/Makefile.am
@@ -18,7 +18,7 @@ AM_CFLAGS = $(CFLAGS) -std=c99 -fPIC
if HAVE_GTK2
shellexecui_gtk2_la_SOURCES = shellexecui.c interface.c support.c callbacks.c interface.h support.h callbacks.h
-shellexecui_gtk2_la_LDFLAGS = -module
+shellexecui_gtk2_la_LDFLAGS = -module -avoid-version
if STATICLINK
GTK_ROOT=@top_srcdir@/$(LIB)/gtk-2.12.12/usr
@@ -33,7 +33,7 @@ endif
if HAVE_GTK3
shellexecui_gtk3_la_SOURCES = shellexecui.c interface.c support.c callbacks.c interface.h support.h callbacks.h
-shellexecui_gtk3_la_LDFLAGS = -module
+shellexecui_gtk3_la_LDFLAGS = -module -avoid-version
if STATICLINK
GTK_ROOT_300=@top_srcdir@/$(LIB)/gtk-3.0.0