summaryrefslogtreecommitdiff
path: root/plugins/mono2stereo
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2011-05-23 13:17:39 +0200
committerGravatar waker <wakeroid@gmail.com>2011-05-23 13:17:39 +0200
commite500400f8a60c3d0656896fb035f3cc1cec5a1f7 (patch)
treeef8878374d8b756e5ab81aadcedd9e52883302a9 /plugins/mono2stereo
parent41a099827ac46b362b69b745ee2fb9bda88187e2 (diff)
mono2stereo: added website and renamed to ddb_mono2stereo
Diffstat (limited to 'plugins/mono2stereo')
-rw-r--r--plugins/mono2stereo/Makefile4
-rw-r--r--plugins/mono2stereo/mono2stereo.c3
2 files changed, 4 insertions, 3 deletions
diff --git a/plugins/mono2stereo/Makefile b/plugins/mono2stereo/Makefile
index 067f074d..0dceaa3a 100644
--- a/plugins/mono2stereo/Makefile
+++ b/plugins/mono2stereo/Makefile
@@ -1,4 +1,4 @@
-CC=gcc
+CC?=gcc
CFLAGS+=-Wall -fPIC -D_GNU_SOURCE -std=c99
@@ -8,7 +8,7 @@ SOURCES=mono2stereo.c
OBJECTS=$(SOURCES:.c=.o)
-OUT=mono2stereo.so
+OUT?=ddb_mono2stereo.so
all: $(SOURCES) $(OUT)
diff --git a/plugins/mono2stereo/mono2stereo.c b/plugins/mono2stereo/mono2stereo.c
index f10a9375..23d0b0d5 100644
--- a/plugins/mono2stereo/mono2stereo.c
+++ b/plugins/mono2stereo/mono2stereo.c
@@ -160,6 +160,7 @@ static DB_dsp_t plugin = {
"along with this program; if not, write to the Free Software\n"
"Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.\n"
,
+ .plugin.website = "http://deadbeef.sf.net",
.num_params = m2s_num_params,
.get_param_name = m2s_get_param_name,
.set_param = m2s_set_param,
@@ -169,7 +170,7 @@ static DB_dsp_t plugin = {
};
DB_plugin_t *
-mono2stereo_load (DB_functions_t *f) {
+ddb_mono2stereo_load (DB_functions_t *f) {
deadbeef = f;
return &plugin.plugin;
}