summaryrefslogtreecommitdiff
path: root/plugins/ffap
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <waker@users.sourceforge.net>2013-09-10 20:35:45 +0200
committerGravatar Alexey Yakovenko <waker@users.sourceforge.net>2013-09-10 20:39:20 +0200
commit8aaa885aae14ef3bd350b847e4e410d5dc3d0197 (patch)
tree60c215a306b2e36c540f48bfc5fa8f551914c5d6 /plugins/ffap
parente1ded6f39ea4c00e4839cfed00330348cd75bb8f (diff)
fixed ffap build on osx
Diffstat (limited to 'plugins/ffap')
-rw-r--r--plugins/ffap/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/plugins/ffap/Makefile.am b/plugins/ffap/Makefile.am
index 4f6ce038..24cd7909 100644
--- a/plugins/ffap/Makefile.am
+++ b/plugins/ffap/Makefile.am
@@ -8,16 +8,20 @@ EXTRA_DIST = dsputil_yasm.asm x86inc.asm
SUFFIXES = .asm
if HAVE_YASM
+if APE_USE_YASM
INTEL_SRC=dsputil_yasm.asm
ffap_la_DEPENDENCIES=dsputil_yasm.lo
endif
+endif
ffap_la_SOURCES = ffap.c $(INTEL_SRC)
if HAVE_YASM
+if APE_USE_YASM
.asm.lo:
$(LIBTOOL) --tag=CC --mode=compile $(YASM) $(YASM_FLAGS) -o $@ $<
endif
+endif
ffap_la_LDFLAGS = -module -lm