summaryrefslogtreecommitdiff
path: root/plugins/dca/Makefile.am
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <wakeroid@gmail.com>2010-06-08 22:00:06 +0200
committerGravatar Alexey Yakovenko <wakeroid@gmail.com>2010-06-08 22:00:06 +0200
commitd11a3e9505338513f1aed652a1d5fb3aed7dd119 (patch)
tree75fe0bfe4ac6a13563b1f03b274717d77c7487fb /plugins/dca/Makefile.am
parent32144fc445c968da9524352dec35740eefa89820 (diff)
dts decoder using libdca
Diffstat (limited to 'plugins/dca/Makefile.am')
-rw-r--r--plugins/dca/Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/plugins/dca/Makefile.am b/plugins/dca/Makefile.am
new file mode 100644
index 00000000..b0659dce
--- /dev/null
+++ b/plugins/dca/Makefile.am
@@ -0,0 +1,31 @@
+if HAVE_DCA
+
+pkglib_LTLIBRARIES = dca.la
+
+dca_la_SOURCES = dcaplug.c\
+extract_dca.c\
+getopt.c\
+gettimeofday.c\
+parse.c\
+bitstream.c\
+downmix.c\
+convert2s16.c\
+plugins/dca/audio_out.h\
+plugins/dca/dca.h\
+plugins/dca/dts.h\
+plugins/dca/getopt.h\
+plugins/dca/gettimeofday.h\
+plugins/dca/tendra.h\
+plugins/dca/dca_internal.h\
+plugins/dca/tables_adpcm.h\
+plugins/dca/tables_fir.h\
+plugins/dca/tables.h\
+plugins/dca/tables_huffman.h\
+plugins/dca/tables_quantization.h\
+plugins/dca/tables_vq.h
+
+dca_la_LDFLAGS = -module
+
+AM_CFLAGS = $(CFLAGS) -fPIC
+
+endif