summaryrefslogtreecommitdiff
path: root/plugins/adplug
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2012-03-20 20:52:29 +0100
committerGravatar waker <wakeroid@gmail.com>2012-03-20 20:52:29 +0100
commit6d8f99ce8f827e95c09bfb33251fe210ce0c2c39 (patch)
tree4c320a0161509d12289d3eb1ad99ae572fff5ce9 /plugins/adplug
parent010c5663fca158493ce9174407002d2fe665e2f5 (diff)
0.5.2-rc2 fixes
Diffstat (limited to 'plugins/adplug')
-rw-r--r--plugins/adplug/Makefile.am4
-rw-r--r--plugins/adplug/adplug-db.cpp6
2 files changed, 8 insertions, 2 deletions
diff --git a/plugins/adplug/Makefile.am b/plugins/adplug/Makefile.am
index 3bd6fd85..6a56e1b8 100644
--- a/plugins/adplug/Makefile.am
+++ b/plugins/adplug/Makefile.am
@@ -5,9 +5,9 @@ adlibdir = $(libdir)/$(PACKAGE)
pkglib_LTLIBRARIES = adplug.la
AM_CFLAGS = $(CFLAGS) -std=c99 -I$(adplugpath)/adplug -I$(adplugpath)/libbinio -fPIC
-adplug_la_LDFLAGS = -module -nostdlib
+adplug_la_LDFLAGS = -module -nostdlib -lm -lsupc++
-AM_CPPFLAGS = $(CXXFLAGS) -Dstricmp=strcasecmp -DVERSION=\"2.1\" -I$(adplugpath)/adplug -I$(adplugpath)/libbinio -fno-exceptions -fno-rtti -nostdlib -fno-unwind-tables -fPIC
+AM_CPPFLAGS = $(CXXFLAGS) -Dstricmp=strcasecmp -DVERSION=\"2.1\" -I$(adplugpath)/adplug -I$(adplugpath)/libbinio -fno-exceptions -fno-rtti -fno-unwind-tables
adplug_la_SOURCES = plugin.c\
adplug-db.cpp\
diff --git a/plugins/adplug/adplug-db.cpp b/plugins/adplug/adplug-db.cpp
index 98005298..f6936ff6 100644
--- a/plugins/adplug/adplug-db.cpp
+++ b/plugins/adplug/adplug-db.cpp
@@ -42,6 +42,12 @@ int _Unwind_GetDataRelBase;
int _Unwind_GetRegionStart;
int _Unwind_SetGR;
int _Unwind_GetIPInfo;
+//int __cxa_pure_virtual;
+////int _Znaj;
+////int _ZdaPv;
+//int __cxa_guard_release;
+////int _ZdlPv;
+//int __cxa_guard_acquire;
extern "C" {