summaryrefslogtreecommitdiff
path: root/plugins/aac
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <waker@users.sourceforge.net>2013-10-03 23:05:37 +0200
committerGravatar Alexey Yakovenko <waker@users.sourceforge.net>2013-10-03 23:05:37 +0200
commit100122b7d3471e9543306159bf351ebf27dd6f4d (patch)
treebb5952708eac873aa8bf46b2df2d4cfd2e51f543 /plugins/aac
parent715bbb48b4f4d172f73173c9391f416953961464 (diff)
fix stuff to pass make distcheck
Diffstat (limited to 'plugins/aac')
-rw-r--r--plugins/aac/Makefile.am16
1 files changed, 3 insertions, 13 deletions
diff --git a/plugins/aac/Makefile.am b/plugins/aac/Makefile.am
index 5a532d8f..642219b3 100644
--- a/plugins/aac/Makefile.am
+++ b/plugins/aac/Makefile.am
@@ -2,20 +2,10 @@ if HAVE_AAC
aacpath=@top_srcdir@/plugins/aac
aacdir = $(libdir)/$(PACKAGE)
pkglib_LTLIBRARIES = aac.la
-aac_la_SOURCES = aac.c aac_parser.c aac_parser.h\
-../libmp4ff/mp4atom.c\
-../libmp4ff/mp4ff.c\
-../libmp4ff/mp4meta.c\
-../libmp4ff/mp4sample.c\
-../libmp4ff/mp4tagupdate.c\
-../libmp4ff/mp4util.c\
-../libmp4ff/mp4ff.h\
-../libmp4ff/mp4ffint.h\
-../libmp4ff/mp4ff_int_types.h
-
+aac_la_SOURCES = aac.c aac_parser.c aac_parser.h
aac_la_LDFLAGS = -module
-aac_la_LIBADD = $(LDADD) $(FAAD2_LIBS)
-AM_CFLAGS = $(CFLAGS) -std=c99 -DUSE_MP4FF -DUSE_TAGGING -I$(aacpath)/../libmp4ff
+aac_la_LIBADD = $(LDADD) $(FAAD2_LIBS) ../libmp4ff/libmp4ff.a
+AM_CFLAGS = $(CFLAGS) -std=c99 -DUSE_MP4FF -DUSE_TAGGING -I@top_srcdir@/plugins/libmp4ff
endif