summaryrefslogtreecommitdiff
path: root/playlist.c
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <wakeroid@gmail.com>2010-05-30 15:48:40 +0200
committerGravatar Alexey Yakovenko <wakeroid@gmail.com>2010-05-30 15:48:40 +0200
commit754fc088625e95ec3266d2db5a148cc95db51557 (patch)
treef694659121e9afc6f99e0293fd85f17cd01c5890 /playlist.c
parent52332cffdbbe27776b125061a17e14a47dfa55be (diff)
parent288ad1d3a653383c59c0e1f1b088ef652a6c2149 (diff)
Merge branch 'i18n' into devel
Conflicts: configure.ac
Diffstat (limited to 'playlist.c')
-rw-r--r--playlist.c8
1 files changed, 6 insertions, 2 deletions
diff --git a/playlist.c b/playlist.c
index 51470a29..f2d07dd1 100644
--- a/playlist.c
+++ b/playlist.c
@@ -15,6 +15,9 @@
You should have received a copy of the GNU General Public License
along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
+#ifdef HAVE_CONFIG_H
+# include <config.h>
+#endif
#include <stdlib.h>
#include <string.h>
#include <dirent.h>
@@ -32,6 +35,7 @@
#endif
#include <limits.h>
#include <errno.h>
+#include "gettext.h"
#include "playlist.h"
#include "streamer.h"
#include "messagepump.h"
@@ -355,7 +359,7 @@ plt_remove (int plt) {
trace ("warning: deleting last playlist\n");
pl_clear ();
free (playlist->title);
- playlist->title = strdup ("Default");
+ playlist->title = strdup (_("Default"));
PLT_UNLOCK;
plt_gen_conf ();
plug_trigger_event (DB_EV_PLAYLISTSWITCH, 0);
@@ -2220,7 +2224,7 @@ pl_load_all (void) {
fprintf (stderr, "error: cannot make string with default playlist path\n");
return -1;
}
- if (plt_add (plt_get_count (), "Default") < 0) {
+ if (plt_add (plt_get_count (), _("Default")) < 0) {
return -1;
}
return pl_load (defpl);