summaryrefslogtreecommitdiff
path: root/junklib.c
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2012-10-19 17:42:18 +0200
committerGravatar waker <wakeroid@gmail.com>2012-10-19 17:42:18 +0200
commit9371c5953b51235388fb657fba288b9a99005ad1 (patch)
treec20e1f98d15ba90597f5fc5f44a144a763e784de /junklib.c
parent73a6c7eea6ccf48f0d2872997b93c6ee5b78fac4 (diff)
parentcf99fd6ea3cd728fa643e7d34e6edbf026f0feb5 (diff)
Merge branch 'master' into devel
Conflicts: configure.ac streamer.c streamer.h
Diffstat (limited to 'junklib.c')
-rw-r--r--junklib.c19
1 files changed, 12 insertions, 7 deletions
diff --git a/junklib.c b/junklib.c
index c264e51d..5ebfbf1d 100644
--- a/junklib.c
+++ b/junklib.c
@@ -1,6 +1,9 @@
-/* junklib -- library for reading tags from various audio files for deadbeef player
+/*
+ This file is part of Deadbeef Player source code
http://deadbeef.sourceforge.net
+ library for reading tags from various audio files
+
Copyright (C) 2009-2012 Alexey Yakovenko
This software is provided 'as-is', without any express or implied
@@ -1360,13 +1363,15 @@ junk_apev2_read_full (playItem_t *it, DB_apev2_tag_t *tag_store, DB_FILE *fp) {
}
value[itemsize] = 0;
- // replace 0s with \n
- uint8_t *p = value;
- while (p < value + itemsize - 1) {
- if (*p == 0) {
- *p = '\n';
+ if ((flags&6) == 0 && strncasecmp (key, "cover art ", 10)) {
+ // replace 0s with \n
+ uint8_t *p = value;
+ while (p < value + itemsize - 1) {
+ if (*p == 0) {
+ *p = '\n';
+ }
+ p++;
}
- p++;
}
junk_apev2_add_frame (it, tag_store, &tail, itemsize, itemflags, key, value);