summaryrefslogtreecommitdiff
path: root/include/curl/Makefile.am
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2010-11-01 18:39:58 +0100
committerGravatar waker <wakeroid@gmail.com>2010-11-01 18:39:58 +0100
commite0e7250cf34b03edb61195f0e3d28aeb85922372 (patch)
tree14cdb820cbd14fabe7cf68b73f340cb03d748604 /include/curl/Makefile.am
parent86c756deeb6effd9b29968a3649f8387c0b6d62a (diff)
0.4.3-portable-build1
Diffstat (limited to 'include/curl/Makefile.am')
-rw-r--r--include/curl/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/include/curl/Makefile.am b/include/curl/Makefile.am
new file mode 100644
index 00000000..a3b44438
--- /dev/null
+++ b/include/curl/Makefile.am
@@ -0,0 +1,25 @@
+pkginclude_HEADERS = \
+ curl.h curlver.h easy.h mprintf.h stdcheaders.h types.h multi.h \
+ typecheck-gcc.h curlbuild.h curlrules.h
+
+pkgincludedir= $(includedir)/curl
+
+# curlbuild.h does not exist in the git tree. When the original libcurl
+# source code distribution archive file is created, curlbuild.h.dist is
+# renamed to curlbuild.h and included in the tarball so that it can be
+# used directly on non-configure systems.
+#
+# The distributed curlbuild.h will be overwritten on configure systems
+# when the configure script runs, with one that is suitable and specific
+# to the library being configured and built.
+#
+# curlbuild.h.in is the distributed template file from which the configure
+# script creates curlbuild.h at library configuration time, overwiting the
+# one included in the distribution archive.
+#
+# curlbuild.h.dist is not included in the source code distribution archive.
+
+EXTRA_DIST = curlbuild.h.in
+
+DISTCLEANFILES = curlbuild.h
+