summaryrefslogtreecommitdiff
path: root/deadbeef.h
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2011-10-23 11:50:41 +0200
committerGravatar waker <wakeroid@gmail.com>2011-10-23 11:50:41 +0200
commita9c813ddbda28a2d0beff104fe8cf80299292533 (patch)
tree5630dfd20c5e4484148dc4fde06fdb2a0e9aeefa /deadbeef.h
parent2f2937a5554d4cdca177eb546a0e0c449b16c700 (diff)
parent50208fdf54d7afaf8b42abc511ddc675b9475184 (diff)
Merge branch 'master' into devel
Conflicts: deadbeef.h metacache.c playlist.c plugins.c plugins/gtkui/Makefile.am plugins/gtkui/ddbcellrenderertextmultiline.c plugins/gtkui/ddbcellrenderertextmultiline.h plugins/gtkui/ddbequalizer.c plugins/gtkui/ddbequalizer.h plugins/gtkui/ddbseekbar.c plugins/gtkui/ddbseekbar.h plugins/gtkui/ddbtabstrip.c plugins/gtkui/fileman.c plugins/gtkui/gtkui.c plugins/gtkui/interface.c plugins/gtkui/plcommon.c plugins/gtkui/trkproperties.c
Diffstat (limited to 'deadbeef.h')
-rw-r--r--deadbeef.h10
1 files changed, 7 insertions, 3 deletions
diff --git a/deadbeef.h b/deadbeef.h
index 700b4a35..9b9d3bae 100644
--- a/deadbeef.h
+++ b/deadbeef.h
@@ -636,7 +636,7 @@ typedef struct {
// junk reading/writing
int (*junk_id3v1_read) (DB_playItem_t *it, DB_FILE *fp);
int (*junk_id3v1_find) (DB_FILE *fp);
- int (*junk_id3v1_write) (FILE *fp, DB_playItem_t *it);
+ int (*junk_id3v1_write) (FILE *fp, DB_playItem_t *it, const char *enc);
int (*junk_id3v2_find) (DB_FILE *fp, int *psize);
int (*junk_id3v2_read) (DB_playItem_t *it, DB_FILE *fp);
int (*junk_id3v2_read_full) (DB_playItem_t *it, DB_id3v2_tag_t *tag, DB_FILE *fp);
@@ -729,16 +729,20 @@ typedef struct {
int (*dsp_preset_save) (const char *fname, struct ddb_dsp_context_s *head);
void (*dsp_preset_free) (struct ddb_dsp_context_s *head);
- // new 1.2 APIs
+ // ******* new 1.2 APIs ********
ddb_playlist_t *(*plt_alloc) (const char *title);
void (*plt_free) (ddb_playlist_t *plt);
- //int (*plt_insert) (ddb_playlist_t *plt, int before);
+
void (*plt_set_fast_mode) (ddb_playlist_t *plt, int fast);
int (*plt_is_fast_mode) (ddb_playlist_t *plt);
+
const char * (*metacache_add_string) (const char *str);
void (*metacache_remove_string) (const char *str);
void (*metacache_ref) (const char *str);
void (*metacache_unref) (const char *str);
+
+ // this function must return original un-overriden value (ignoring the keys prefixed with '!')
+ const char *(*pl_find_meta_raw) (DB_playItem_t *it, const char *key);
} DB_functions_t;
enum {