summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-29 22:47:50 +0200
committerGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-29 22:47:50 +0200
commitfc2689bbd0af9323a366d6fe6b37f613e28fc53f (patch)
tree32cef377a22338d1bde1e26d32e0313318651550 /configure.ac
parent7ad596b7eb25cc2ab18b439d6159b0e12205c2f5 (diff)
vfs_curl WIP
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 14 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 2f268ce4..062cdd28 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,12 +47,16 @@ if test ${HAVE_SSE2}; then
fi
AC_SUBST(SIMD_FLAGS)
-dnl lastfm plugin
+dnl curl lib
AC_CHECK_LIB([curl], [main], [HAVE_CURL=1])
if test ${HAVE_CURL}; then
- LFM_LIBS="-lcurl"
+ CURL_LIBS="-lcurl"
+ AC_SUBST(CURL_LIBS)
+fi
+
+dnl lastfm plugin
+if test ${HAVE_CURL}; then
LFM_DIR="plugins/lastfm"
- AC_SUBST(LFM_LIBS)
AC_SUBST(LFM_DIR)
fi
@@ -106,6 +110,12 @@ if test ${HAVE_SNDFILE} ; then
AC_SUBST(SNDFILE_DIR)
fi
+dnl lastfm plugin
+if test ${HAVE_CURL}; then
+ VFS_CURL_DIR="plugins/vfs_curl"
+ AC_SUBST(VFS_CURL_DIR)
+fi
+
AC_OUTPUT([
Makefile
pixmaps/Makefile
@@ -122,6 +132,7 @@ plugins/vorbis/Makefile
plugins/flac/Makefile
plugins/wavpack/Makefile
plugins/sndfile/Makefile
+plugins/vfs_curl/Makefile
deadbeef.desktop
])