summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-10-09 21:54:26 +0200
committerGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-10-09 21:54:26 +0200
commitf972d083eb6d8e6ef68485f839a969d610a11837 (patch)
treeab4e596ea06ff07771609afa64ae7ac60a40cffd /configure.ac
parent0fee0b8e3140129b9522434dc3b16e3b29cc8aee (diff)
several fixes to initial cdda implementation
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0b2808f1..86efa100 100644
--- a/configure.ac
+++ b/configure.ac
@@ -126,6 +126,17 @@ if test ${HAVE_FAAD} && test ${HAVE_MP4FF} ; then
AC_SUBST(FAAD2_DIR)
fi
+dnl cdda plugin
+AC_CHECK_LIB([cdio], [main], [HAVE_CDIO=1])
+AC_CHECK_LIB([cddb], [main], [HAVE_CDDB=1])
+
+if test ${HAVE_CDIO} && test ${HAVE_CDDB}; then
+ CDDA_LIBS="-lcdio -lcddb"
+ CDDA_DIR="plugins/cdda"
+ AC_SUBST(CDDA_LIBS)
+ AC_SUBST(CDDA_DIR)
+fi
+
AC_OUTPUT([
Makefile
pixmaps/Makefile
@@ -144,6 +155,7 @@ plugins/wavpack/Makefile
plugins/sndfile/Makefile
plugins/vfs_curl/Makefile
plugins/faad2/Makefile
+plugins/cdda/Makefile
deadbeef.desktop
])