summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <waker@users.sourceforge.net>2014-06-07 11:56:38 +0200
committerGravatar Alexey Yakovenko <waker@users.sourceforge.net>2014-06-07 11:56:38 +0200
commitebc2929f0001ebe6563b4af6ab64ef217498c121 (patch)
treef4eaf7bdd4f2eb296df1135b8833d5dc054fb868 /configure.ac
parent82ef88e5865d7a5767df9155e0315c8ca0974766 (diff)
vorbis and flac static build fix
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index b0d74f82..76338d66 100644
--- a/configure.ac
+++ b/configure.ac
@@ -353,7 +353,7 @@ dnl vorbis plugin
AS_IF([test "${enable_vorbis}" != "no"], [
AS_IF([test "${enable_staticlink}" != "no"], [
HAVE_VORBISPLUGIN=yes
- VORBIS_LIBS="../../$LIB/lib/libogg.a ../../$LIB/lib/libvorbis.a ../../$LIB/lib/libvorbisfile.a"
+ VORBIS_LIBS="-lvorbisfile -lvorbis -lm -logg"
VORBIS_CFLAGS="-I../../$LIB/include"
AC_SUBST(VORBIS_LIBS)
AC_SUBST(VORBIS_CFLAGS)
@@ -362,7 +362,7 @@ AS_IF([test "${enable_vorbis}" != "no"], [
AC_CHECK_LIB([vorbisfile], [main], [HAVE_VORBISFILE=yes])
AS_IF([test "$HAVE_VORBIS" = "yes" -a "${HAVE_VORBISFILE}" = "yes"], [
HAVE_VORBISPLUGIN=yes
- VORBIS_LIBS="-logg -lvorbis -lvorbisfile"
+ VORBIS_LIBS="-lvorbis -lvorbisfile"
AC_SUBST(VORBIS_LIBS)
])
])
@@ -371,7 +371,7 @@ AS_IF([test "${enable_vorbis}" != "no"], [
dnl libogg for oggedit
AS_IF([test "${enable_staticlink}" != "no"], [
HAVE_OGG=yes
- OGG_LIBS="../../$LIB/lib/libogg.a"
+ OGG_LIBS="-logg"
OGG_CFLAGS="-I../../$LIB/include"
AC_SUBST(OGG_LIBS)
AC_SUBST(OGG_CFLAGS)
@@ -390,7 +390,7 @@ AS_IF([test "${enable_flac}" != "no"], [
AS_IF([test "${enable_staticlink}" != "no"], [
HAVE_FLACPLUGIN=yes
FLAC_CFLAGS="-I../../$LIB/include"
- FLAC_LIBS="../../$LIB/lib/libFLAC.a"
+ FLAC_LIBS="-lFLAC"
AC_SUBST(FLAC_CFLAGS)
AC_SUBST(FLAC_LIBS)
], [