summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-27 17:10:09 +0200
committerGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-27 17:10:09 +0200
commiteafa6122f222db59f6f03b1b56e5738f0fe03bbb (patch)
tree1edcf9549f105045d2436ff2028dcf98ae790e2e /configure.ac
parent7912e7c4aae997c4df0abc9692ed59651b32255a (diff)
added libsndfile decoder
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b8d856d8..2f268ce4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,6 +96,16 @@ if test ${HAVE_WAVPACK} ; then
AC_SUBST(WAVPACK_DIR)
fi
+dnl libsndfile plugin
+AC_CHECK_LIB([sndfile], [main], [HAVE_SNDFILE=1])
+
+if test ${HAVE_SNDFILE} ; then
+ SNDFILE_LIBS="-lsndfile"
+ SNDFILE_DIR="plugins/sndfile"
+ AC_SUBST(SNDFILE_LIBS)
+ AC_SUBST(SNDFILE_DIR)
+fi
+
AC_OUTPUT([
Makefile
pixmaps/Makefile
@@ -111,6 +121,7 @@ plugins/mpgmad/Makefile
plugins/vorbis/Makefile
plugins/flac/Makefile
plugins/wavpack/Makefile
+plugins/sndfile/Makefile
deadbeef.desktop
])