summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar waker <wakeroid@gmail.com>2011-10-10 19:26:44 +0200
committerGravatar waker <wakeroid@gmail.com>2011-10-10 19:26:44 +0200
commitc9fa5c004a317b5d48360d7b4deb0b3f05da50f7 (patch)
tree54d4c5f2fc2dd9765d108d07898ab627d34bdcf8 /configure.ac
parentfaae73cdf6fbc248b7f91ce4478a4908f2f32edf (diff)
yasm is now mandatory for building ape plugin on x86 and x86_64
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 21b85a84..e53e44d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,7 @@ case "$host" in
AC_DEFINE(ARCH_X86_32, 1, [architecture is x86])
LIB="../deadbeef-deps/lib-x86-32"
YASM_FLAGS="-f elf -D ARCH_X86_32 -m x86"
+ APE_USE_YASM=yes
;;
x86_64-apple-*)
AC_DEFINE(ARCH_X86_64_OSX, 1, [architecture is x86_64 for OSX])
@@ -38,6 +39,7 @@ case "$host" in
AC_DEFINE(ARCH_X86_64, 1, [architecture is x86_64])
LIB="../deadbeef-deps/lib-x86-64"
YASM_FLAGS="-f elf -D ARCH_X86_64 -m amd64"
+ APE_USE_YASM=yes
;;
powerpc-*-* )
AC_DEFINE(ARCH_PPC_32, 1, [architecture is ppc32])
@@ -447,7 +449,7 @@ if test "x$enable_adplug" != "xno" ; then
HAVE_ADPLUG=yes
fi
-if test "x$enable_ffap" != "xno" ; then
+if test "x$enable_ffap" != "xno" && ( test "x$HAVE_YASM" == "xyes" || test "x$APE_USE_YASM" != "xyes" ) ; then
HAVE_FFAP=yes
fi