summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <waker@users.sourceforge.net>2014-06-06 23:24:07 +0200
committerGravatar Alexey Yakovenko <waker@users.sourceforge.net>2014-06-06 23:24:07 +0200
commita70af803be4c8abe4833864e1b5bc7103a590ad4 (patch)
tree845bfac46bd9c8094248cdae8057792b56160232 /configure.ac
parent72fe56200de7a61594c0d1f77074ca3dae95008b (diff)
fixed tools/apbuild/buildlist to work on modern systems with multulib; flac/ogg static link WIP
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 40f5703c..b0d74f82 100644
--- a/configure.ac
+++ b/configure.ac
@@ -353,7 +353,7 @@ dnl vorbis plugin
AS_IF([test "${enable_vorbis}" != "no"], [
AS_IF([test "${enable_staticlink}" != "no"], [
HAVE_VORBISPLUGIN=yes
- VORBIS_LIBS="../../$LIB/lib/libogg.a ../../$LIB/lib/libvorbis.a ../../$LIB/lib/libvorbisenc.a ../../$LIB/lib/libvorbisfile.a"
+ VORBIS_LIBS="../../$LIB/lib/libogg.a ../../$LIB/lib/libvorbis.a ../../$LIB/lib/libvorbisfile.a"
VORBIS_CFLAGS="-I../../$LIB/include"
AC_SUBST(VORBIS_LIBS)
AC_SUBST(VORBIS_CFLAGS)
@@ -362,7 +362,7 @@ AS_IF([test "${enable_vorbis}" != "no"], [
AC_CHECK_LIB([vorbisfile], [main], [HAVE_VORBISFILE=yes])
AS_IF([test "$HAVE_VORBIS" = "yes" -a "${HAVE_VORBISFILE}" = "yes"], [
HAVE_VORBISPLUGIN=yes
- VORBIS_LIBS="-lvorbis -lvorbisfile"
+ VORBIS_LIBS="-logg -lvorbis -lvorbisfile"
AC_SUBST(VORBIS_LIBS)
])
])
@@ -371,7 +371,7 @@ AS_IF([test "${enable_vorbis}" != "no"], [
dnl libogg for oggedit
AS_IF([test "${enable_staticlink}" != "no"], [
HAVE_OGG=yes
- OGG_LIBS="../../$LIB/lib/libogg.a ../../$LIB/lib/libvorbis.a ../../$LIB/lib/libvorbisenc.a ../../$LIB/lib/libvorbisfile.a"
+ OGG_LIBS="../../$LIB/lib/libogg.a"
OGG_CFLAGS="-I../../$LIB/include"
AC_SUBST(OGG_LIBS)
AC_SUBST(OGG_CFLAGS)
@@ -390,7 +390,7 @@ AS_IF([test "${enable_flac}" != "no"], [
AS_IF([test "${enable_staticlink}" != "no"], [
HAVE_FLACPLUGIN=yes
FLAC_CFLAGS="-I../../$LIB/include"
- FLAC_LIBS="../../$LIB/lib/libFLAC.a ../../$LIB/lib/libogg.a"
+ FLAC_LIBS="../../$LIB/lib/libFLAC.a"
AC_SUBST(FLAC_CFLAGS)
AC_SUBST(FLAC_LIBS)
], [