summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <wakeroid@gmail.com>2010-01-20 21:48:03 +0100
committerGravatar Alexey Yakovenko <wakeroid@gmail.com>2010-01-20 21:48:03 +0100
commit4872a51d33d9b449f8270a97aa3497e28cd0b3eb (patch)
treef22fc2fb1c3e0741ef401d569afe2f1277cb822d /configure.ac
parent56650db1e4d6f39d11167c308b23e70507b05a5c (diff)
oss plugin updates (supports both v3 and v4 now)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 21 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index f51d527a..f1ec43fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -176,19 +176,19 @@ if test ${HAVE_FFMPEG}; then
AC_SUBST(FFMPEG_DIR)
fi
-dnl *** OSS4 output (partly stolen from audacious)
-have_oss4=no
+dnl *** OSS output (partly stolen from audacious)
+have_oss=no
-AC_MSG_CHECKING(for OSS4 include dir)
-OSS4_CFLAGS=""
+AC_MSG_CHECKING(for OSS include dir)
+OSS_CFLAGS=""
if test -f "/etc/oss.conf" ; then
for i in `cat /etc/oss.conf`; do
t=`echo $i | sed -e 's/OSSLIBDIR=//'`
if test "x$i" != "x$t" ; then
if test -f "$t/include/sys/soundcard.h" -o -f "$i/include/soundcard.h" ; then
- OSS4_CFLAGS="-I$t/include"
- AC_MSG_RESULT([$OSS4_CFLAGS])
- have_oss4=yes
+ OSS_CFLAGS="-I$t/include/sys"
+ AC_MSG_RESULT([$OSS_CFLAGS])
+ have_oss=yes
fi
fi
done
@@ -196,11 +196,11 @@ else
AC_MSG_RESULT([not found])
fi
-if test "x$have_oss4" != "xyes"; then
- AC_MSG_CHECKING(for /usr/include/sys/soundcard.h)
+if test "x$have_oss" != "xyes"; then
+ AC_MSG_CHECKING(for sys/soundcard.h)
AC_CHECK_HEADERS(sys/soundcard.h)
if test "x${ac_cv_header_sys_soundcard_h}" = "xyes" ; then
- have_oss4=yes
+ have_oss=yes
AC_MSG_RESULT([found])
else
AC_MSG_RESULT([not found])
@@ -208,18 +208,18 @@ if test "x$have_oss4" != "xyes"; then
fi
-if test "x$have_oss4" = "xyes"; then
- OSS4_DIR="plugins/oss"
- AC_SUBST(OSS4_CFLAGS)
- AC_SUBST(OSS4_DIR)
+if test "x$have_oss" = "xyes"; then
+ OSS_DIR="plugins/oss"
+ AC_SUBST(OSS_CFLAGS)
+ AC_SUBST(OSS_DIR)
fi
-echo
-echo "have_oss4=$have_oss4"
-echo "OSS4_CFLAGS=$OSS4_CFLAGS"
-echo "OSS4_LIBS=$OSS4_LIBS"
-echo "OSS4_DIR=$OSS4_DIR"
-echo
+dnl echo
+dnl echo "have_oss=$have_oss"
+dnl echo "OSS_CFLAGS=$OSS_CFLAGS"
+dnl echo "OSS_LIBS=$OSS_LIBS"
+dnl echo "OSS_DIR=$OSS_DIR"
+dnl echo
dnl print summary
@@ -257,7 +257,7 @@ dnl PRINT_PLUGIN_INFO([faad2],[aac/mp4 player],[test $HAVE_FAAD && test $HAVE_MP
PRINT_PLUGIN_INFO([cdda],[cd audio player],[test $HAVE_CDIO && test $HAVE_CDDB])
PRINT_PLUGIN_INFO([gtkui],[GTK user interface],[test $HAVE_GTK])
PRINT_PLUGIN_INFO([ffmpeg],[ffmpeg codecs],[test $HAVE_FFMPEG])
-PRINT_PLUGIN_INFO([oss],[oss4 output plugin],[test "x$have_oss4" = "xyes"])
+PRINT_PLUGIN_INFO([oss],[oss output plugin],[test "x$have_oss" = "xyes"])
echo
AC_OUTPUT([