summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <waker@users.sourceforge.net>2014-02-08 23:12:15 +0100
committerGravatar Alexey Yakovenko <waker@users.sourceforge.net>2014-02-08 23:12:15 +0100
commit32a11747dd6849867b0bb934d6a7e89b496ee230 (patch)
tree81d1a5785e35d5151ff545a1bfd8b5d9018d6b12 /configure.ac
parente6a466562dd3356781ffc6381abccebb26440246 (diff)
take static build dependencies from static-deps folder, instead of ../deadbeef-deps
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index a36f2a70..5db0f91d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,37 +30,37 @@ AC_DEFINE_UNQUOTED(LOCALEDIR, "${prefix}/${DATADIRNAME}/locale", [Name of gettex
case "$host" in
i686-apple-*)
AC_DEFINE(ARCH_X86_32, 1, [architecture is x86 on OSX])
- LIB="../deadbeef-deps/lib-x86-32-apple"
+ LIB="static-deps/lib-x86-32-apple"
YASM_FLAGS="-f macho32 -D ARCH_X86_32 -m x86 -DPREFIX"
APE_USE_YASM=yes
OS_OSX=yes
;;
x86_64-apple-*)
AC_DEFINE(ARCH_X86_64, 1, [architecture is x86_64 on OSX])
- LIB="../deadbeef-deps/lib-x86-64-apple"
+ LIB="static-deps/lib-x86-64-apple"
YASM_FLAGS="-f macho64 -D ARCH_X86_64 -m amd64 -DPIC -DPREFIX"
APE_USE_YASM=yes
OS_OSX=yes
;;
i386-*-* | i486-*-* | i586-*-* | i686-*-* | i86pc-*-*)
AC_DEFINE(ARCH_X86_32, 1, [architecture is x86])
- LIB="../deadbeef-deps/lib-x86-32"
+ LIB="static-deps/lib-x86-32"
YASM_FLAGS="-f elf -D ARCH_X86_32 -m x86"
APE_USE_YASM=yes
;;
x86_64-*-* | amd64-*-*)
AC_DEFINE(ARCH_X86_64, 1, [architecture is x86_64])
- LIB="../deadbeef-deps/lib-x86-64"
+ LIB="static-deps/lib-x86-64"
YASM_FLAGS="-f elf -D ARCH_X86_64 -m amd64"
APE_USE_YASM=yes
;;
powerpc-*-* )
AC_DEFINE(ARCH_PPC_32, 1, [architecture is ppc32])
- LIB="../deadbeef-deps/lib-ppc-32"
+ LIB="static-deps/lib-ppc-32"
;;
powerpc64-*-* )
AC_DEFINE(ARCH_PPC_64, 1, [architecture is ppc64])
- LIB="../deadbeef-deps/lib-ppc-64"
+ LIB="static-deps/lib-ppc-64"
;;
*)
AC_DEFINE(ARCH_UNKNOWN, 1, [architecture is unknown])