summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-27 16:05:44 +0200
committerGravatar Alexey Yakovenko <wakeroid@gmail.com>2009-09-27 16:05:44 +0200
commit326604c8c1ff97f99490d557e1f964b86ec630fa (patch)
tree372328d1f92ef16e50ef6f620aa950a34f919a3c /configure.ac
parent5bf2da4cc9e1e15bbccca82d686203dd1bb408ca (diff)
initial wavpack support
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 794c404c..b8d856d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -86,6 +86,15 @@ if test ${HAVE_FLAC} ; then
AC_SUBST(FLAC_DIR)
fi
+dnl wavpack plugin
+AC_CHECK_LIB([wavpack], [main], [HAVE_WAVPACK=1])
+
+if test ${HAVE_WAVPACK} ; then
+ WAVPACK_LIBS="-lwavpack"
+ WAVPACK_DIR="plugins/wavpack"
+ AC_SUBST(WAVPACK_LIBS)
+ AC_SUBST(WAVPACK_DIR)
+fi
AC_OUTPUT([
Makefile
@@ -101,6 +110,7 @@ plugins/ffap/Makefile
plugins/mpgmad/Makefile
plugins/vorbis/Makefile
plugins/flac/Makefile
+plugins/wavpack/Makefile
deadbeef.desktop
])